Novell is now a part of Micro Focus

Security update for samba

Knowledgebase

(Last modified: 07APR2003)


solutions Security update for samba SuSE Linux Maintenance Web (3c9b83a2cbe0be93ca783bec93dac096)

Applies to

Product(s): SuSE Linux Enterprise Server 7 for IA32
SuSE Linux Office Server

Package: samba
Release: 20030407
Obsoletes: none

Indications

All systems using Samba file and print services should install this
update.

Problem description

A new flaw has been discovered in the samba SMB protocol implementation, known as call_trans2open()-bug.
The flaw is a stack overflow and may allow a remote attacker to gain root access to a system running a samba server.
This package includes the files common to the samba-classic and -ldap version. You have also to install either samba-classic or samba-ldap.

Solution

Please install the updates provided at the location noted below.
Remember to update the package samba-classic as described in acticle "Security update for Samba (package samba-classic)" (http://sdb.suse.de/en/psdb/html/5d90070eaa7c088695edc5171afb5853.html) or samba-ldap as described in article "Security update for Samba (package samba-ldap)" (http://sdb.suse.de/en/psdb/html/3f7caad7ebd4c2abcd492309993ce5ef.html) (depending on your setup) as well.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh samba.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus