Novell Home

Security update for PHP5

Knowledgebase

(Last modified: 05MAR2007)


solutions Security update for PHP5 SuSE Linux Maintenance Web (f36e1cd46e4c288ce275fae334efd2b8)

Applies to

Package: apache2-mod_php5
php5
php5-bcmath
php5-curl
php5-dba
php5-devel
php5-dom
php5-exif
php5-fastcgi
php5-ftp
php5-gd
php5-iconv
php5-imap
php5-ldap
php5-mbstring
php5-mysql
php5-mysqli
php5-pdo
php5-pear
php5-soap
php5-wddx
php5-xmlrpc
php5-pgsql
php5-mhash
php5-odbc
php5-sysvmsg
php5-zip
Product(s): SLE SDK 10 for x86
SLE SDK 10 for IPF
SLE SDK 10 for IBM iSeries and IBM pSeries
SLE SDK 10 for IBM zSeries
SLE SDK 10 for X86-64
SUSE SLES 10 for x86
SUSE SLES 10 for IPF
SUSE SLES 10 for IBM POWER
SUSE SLES 10 for IBM zSeries 64bit
SUSE SLES 10 for AMD64 and Intel EM64T

Release: 20070305
Obsoletes: none

Indications

Everyone using PHP5 should install this update.

Contraindications

None.

Description

This update fixes security problems also fixed in PHP 5.2.1, including following problems:
  • CVE-2007-0906: Multiple buffer overflows in PHP before 5.2.1 allow attackers to cause a denial of service and possibly execute arbitrary code via unspecified vectors in the (1) session, (2) zip, (3) imap, and (4) sqlite extensions; (5) stream filters; and the (6) str_replace, (7) mail, (8) ibase_delete_user, (9) ibase_add_user, and (10) ibase_modify_user functions.
  • CVE-2007-0907: Buffer underflow in PHP before 5.2.1 allows attackers to cause a denial of service via unspecified vectors involving the sapi_header_op function.
  • CVE-2007-0908: The wddx extension in PHP before 5.2.1 allows remote attackers to obtain sensitive information via unspecified vectors.
  • CVE-2007-0909: Multiple format string vulnerabilities in PHP before 5.2.1 might allow attackers to execute arbitrary code via format string specifiers to (1) all of the *print functions on 64-bit systems, and (2) the odbc_result_all function.
  • CVE-2007-0910: Unspecified vulnerability in PHP before 5.2.1 allows attackers to "clobber" certain super-global variables via unspecified vectors.
  • CVE-2007-0911: Off-by-one error in the str_ireplace function in PHP 5.2.1 might allow context-dependent attackers to cause a denial of service (crash).
  • CVE-2006-6383: PHP 5.2.0 and 4.4 allows local users to bypass safe_mode and open_basedir restrictions via a malicious path and a null byte before a ";" in a session_save_path argument, followed by an allowed path, which causes a parsing inconsistency in which PHP validates the allowed path but sets session.save_path to the malicious path.
  • A fix for open_basedir was added to stop mixing up its setting in a virtual host environment.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as RPM packages that can easily be installed onto a running system by using this command:
rpm -Fvh apache2-mod_php5.rpm php5.rpm php5-bcmath.rpm php5-curl.rpm php5-dba.rpm php5-devel.rpm php5-dom.rpm php5-exif.rpm php5-fastcgi.rpm php5-ftp.rpm php5-gd.rpm php5-iconv.rpm php5-imap.rpm php5-ldap.rpm php5-mbstring.rpm php5-mysql.rpm php5-mysqli.rpm php5-pdo.rpm php5-pear.rpm php5-soap.rpm php5-wddx.rpm php5-xmlrpc.rpm php5-pgsql.rpm php5-mhash.rpm php5-odbc.rpm php5-sysvmsg.rpm php5-zip.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© 2014 Novell