Novell is now a part of Micro Focus

Security update for Cyrus SASL2

Knowledgebase

(Last modified: 18DEC2002)


solutions Security update for Cyrus SASL2 SuSE Linux Maintenance Web (e50cab6a1c21b1df19a82f7017457781)

Applies to

Product(s): SuSE Linux Openexchange Server 4

Package: cyrus-sasl2
Release: 20021218
Obsoletes: none

Indications

Everyone having the cyrus-sasl2 libraries installed should install this update.

Contraindications

None.

Problem description

The Cyrus SASL library contains a buffer overflow in the code which handles the user name. This may be used by attackers to execute arbitrary code. Since the Cyrus SASL library is utilized by the Cyrus IMAPd and probably other services, this could lead to a remote compromise of a system having a vulnerable Cyrus SASL library installed.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fhv cyrus-sasl2.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus