Novell is now a part of Micro Focus

Security update for package postgresql-server

Knowledgebase

(Last modified: 28MAR2003)


solutions Security update for package postgresql-server SuSE Linux Maintenance Web (e4028e2dae8413165b3513008c9d2964)

Applies to

Product(s): SuSE Linux Enterprise Server 8 for x86
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM S/390 and IBM zSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Openexchange Server 4
SuSE Linux Enterprise Server 8 for IPF

Package: postgresql-server
Release: 20030328
Obsoletes: none

Indications

This patch should be applied on any PostgreSQL installation. This release is backwards compatible to the previous 7.2.x releases, and does not require a dump/restore of the database.

Contraindications

None.

Problem description

This release includes a fix for some serious problems that have affected all 7.2.x releases. If a VACUUM command is run by a non-superuser, it is sometimes possible for the system to prematurely remove old transaction log data (pg_clog files). This can result in data becoming unrecoverable. All 7.2.x installations are urged to update as soon as possible.
Other changes include:
  • Prevent non-superuser from increasing most recent vacuum info
  • Handle pre-1970 date values in newer versions of glibc
  • Fix possible hang during server shutdown
  • Prevent spinlock hangs on SMP PPC machines
  • Fix pg_dump to properly dump FULL JOIN USING
  • Fix some additional cases of VACUUM "No one parent tuple was found" error
  • Prevent VACUUM from being called inside a function (Bruce)
  • Ensure pg_clog updates are sync'd to disk before marking checkpoint complete
  • Avoid integer overflow during large hash joins
  • Make GROUP commands work when pg_group.grolist is large enough to be toasted
  • Fix errors in datetime tables; some timezone names weren't being recognized
  • Fix integer overflows in circle_poly(), path_encode(), path_add() (Neil)
  • Repair long-standing logic errors in lseg_eq(), lseg_ne(), lseg_center()
  • Add inline assembler for test-and-set on PPC and PPC64.
For the official releases, please have a look at the following sites:
  • http://www.postgresql.org/news.php?NewsID=131
  • http://www.postgresql.org/news.php?NewsID=102

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fhv postgresql-server.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus