Novell is now a part of Micro Focus

Security update for perl-Crypt-CBC

Knowledgebase

(Last modified: 27JUN2006)


solutions Security update for perl-Crypt-CBC SuSE Linux Maintenance Web (d18b4c4955a5b08ab795539029dad425)

Applies to

Package: perl-Crypt-CBC
Product(s): SuSE Linux School Server for i386
SuSE Linux Standard Server 8
SLES SDK 9 for x86
SLES SDK 9 for IPF
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for X86-64
SuSE Linux Openexchange Server 4
Patch: patch-11086
Release: 20060627
Obsoletes: none

Indications

Install this update if you are using perl-Crypt-CBC.

Contraindications

None.

Problem description

The Perl Crypt::CBC module versions through 2.16 produced weak ciphertext when
used with block encryption algorithms with blocksize larger than 8
bytes. (CVE-2006-0898)

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh perl-Crypt-CBC.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus