Novell is now a part of Micro Focus

Security update for GTK


(Last modified: 13SEP2004)

solutions Security update for GTK SuSE Linux Maintenance Web (c612fc734c5a6fef616ae5d75a88d64a)

Applies to

Product(s): SuSE Linux Desktop 1.0

Package: gtk2
Release: 20040913
Obsoletes: none


Everyone should install this update.



Problem description

Three security vulnerabilities have been found in the loader for XPM images of the GTK library. These issues are:
  • Potential heap overflow in pixbuf_create_from_xpm(). (CAN-2004-0782)
  • Potential stack overflow in xpm_extract_color(). (CAN-2004-0783)
  • Potential integer overflow in the ICO icon format loader. (CAN-2004-0788)
Depending on the actual application calling the affected library functions, these bugs may be locally or remotely exploitable.


Please install the updates provided at the location noted below.

Installation notes

This update is provided as RPM packages that can easily be installed onto a running system by using this command:
rpm -Fvh gtk2.rpm gdk-pixbuf.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus