Novell is now a part of Micro Focus

Recommended update for scim

Knowledgebase

(Last modified: 31AUG2006)


solutions Recommended update for scim SuSE Linux Maintenance Web (acc7c755cc639cf013575f3380947e6a)

Applies to

Package: scim
scim-devel
Product(s): SUSE SLED 10 for x86
SUSE SLED 10 for AMD64 and Intel EM64T
SUSE SLES 10 for x86
SUSE SLES 10 for IPF
SUSE SLES 10 for IBM POWER
SUSE SLES 10 for IBM zSeries 64bit
SUSE SLES 10 for AMD64 and Intel EM64T

Release: 20060831
Obsoletes: none

Indications

Install this update if you have cannot use scim in some GNOME/GTK
applications.

Contraindications

None.

Problem description

This patch makes it possible to use scim in non-standard gtk applications
which do not use the gtk main loop. Without this patch, the scim gtk immodule
doesn't get any key events from such an application which makes scim unusable.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh scim.rpm scim-devel.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus