Novell is now a part of Micro Focus

Security update for Ghostscript

Knowledgebase

(Last modified: 02OCT2002)


solutions Security update for Ghostscript SuSE Linux Maintenance Web (942cde3eec75f3be6a90f64e4aa7f813)

Applies to

Product(s): SuSE Linux Enterprise Server 7 for PowerPC

Package: ghostscript-library
Release: 20021002
Obsoletes: none

Indications

Everyone using ghostscript should install this patch.

Contraindications

None.

Problem description

Normally the SAFER command line option of the ghostscript program forbids opening files and the execution of arbitrary commands out from PostScript(tm) files handled by ghostscript. It can be shown that the setup done by the SAFER option of ghostscript 6.51 is reversible. This could be used by an attacker using PostScript(tm) code to become the system user lp used by the printing system.
The new implementation of the SAFER option with this patch strictly forbids command execution used in PostScript(tm) file code.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Uvh ghostscript-library.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus