Novell is now a part of Micro Focus

Security update for heimdal

Knowledgebase

(Last modified: 12APR2005)


solutions Security update for heimdal SuSE Linux Maintenance Web (64c29e56970f2633ff2ac802beb243d1)

Applies to

Package: heimdal
heimdal-lib
Product(s): SuSE Linux Desktop 1.0
Patch: patch-9994
Release: 20050412
Obsoletes: none

Indications

Everyone using the telnet client of the heimdal package should update.

Contraindications

None.

Problem description

This update fixes several vulnerabilities in the telnet client.
  • CAN-2005-0469: A buffer overflow in the LINEMODE suboption command SLC can be exploited by a malicious server to execute arbitrary code on the client site with the privileges of the user running telnet.
  • CAN-2005-0468: Another buffer overflow can be exploited remotely via a malicious server by sending environment variables to the client. The result of this bug is arbitrary code execution too. Note that this bug can also be exploited by clicking on a URL link that uses telnet:// as protocol and points to a server controlled by an attacker.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh heimdal.rpm heimdal-lib.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus