Novell is now a part of Micro Focus

Security update for MozillaFirefox

Knowledgebase

(Last modified: 18APR2006)


solutions Security update for MozillaFirefox SuSE Linux Maintenance Web (5bf7d4b67ee6a73aa73ac37c89c4495a)

Applies to

Package: MozillaFirefox
MozillaFirefox-translations
Product(s): Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Patch: patch-10950
Release: 20060418
Obsoletes: none

Indications

Install this update if you are using Firefox.

Contraindications

None.

Problem description

A number of security issues have been fixed in the Mozilla Firefox browser, which could be used by remote attackers to gain privileges, access to confidential information or cause denial of service attacks.
Full details can be found on http://www.mozilla.org/projects/security/known-vulnerabilities.html
List of issues that were fixed:
  • MFSA 2006-25 Privilege escalation through Print Preview (CVE-2006-1727)
  • MFSA 2006-24 Privilege escalation using crypto.generateCRMFRequest (CVE-2006-1728)
  • MFSA 2006-23 File stealing by changing input type (CVE-2006-1729)
  • MFSA 2006-22 CSS Letter-Spacing Heap Overflow Vulnerability (CVE-2006-1730)
  • MFSA 2006-19 Cross-site scripting using .valueOf.call() (CVE-2006-1731)
  • MFSA 2006-18 Mozilla Firefox Tag Order Vulnerability (CVE-2006-0749)
  • MFSA 2006-17 cross-site scripting through window.controllers (CVE-2006-1732)
  • MFSA 2006-16 Accessing XBL compilation scope via valueOf.call() (CVE-2006-1733)
  • MFSA 2006-15 Privilege escalation using a JavaScript function's cloned parent (CVE-2006-1734)
  • MFSA 2006-14 Privilege escalation via XBL.method.eval (CVE-2006-1735)
  • MFSA 2006-13 Downloading executables with "Save Image As..." (CVE-2006-1736)
  • MFSA 2006-12 Secure-site spoof (requires security warning dialog) (CVE-2006-1740)
  • MFSA 2006-11 Crashes with evidence of memory corruption (rv:1.8) (CVE-2006-1739,CVE-2006-1737,CVE-2006-1738,CVE-2006-1790)
  • MFSA 2006-10 JavaScript garbage-collection hazard audit (CVE-2006-1742)
  • MFSA 2006-09 Cross-site JavaScript injection using event handlers (CVE-2006-1741)
This update brings the Firefox browser up to the fixes in the 1.0.8 release.
We wish to thank the Mozilla Developers and the various bugreporters for reporting and fixing those issues.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh MozillaFirefox.rpm MozillaFirefox-translations.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus