Novell is now a part of Micro Focus

Security update for mysql

Knowledgebase

(Last modified: 26SEP2003)


solutions Security update for mysql SuSE Linux Maintenance Web (3b49a8688cb6eb910eebb12b3f2f89c1)

Applies to

Product(s): SuSE Linux Standard Server 8

Package: mysql
Release: 20030926
Obsoletes: none

Indications

This update should be installed on all systems that run a mysql
database.

Problem description

A buffer overflow has been found in the mysql database. The routine responsible for password checking can overflow a buffer if a "Password" field has a value wider than 16 characters.
This buffer overflow can result in the mysql server executing arbitrary code with the privileges of the mysql user for an attacker who has global administrative privileges. The bug affects the mysql database server only, the other mysql subpackages (mysql-client, mysql-shared, mysql-devel) are unaffected, but update packages are provided as contained in a product to resolve compatibility issues.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh mysql.rpm
After installing this update package, the mysql server daemon has to be restarted for the changes to take effect. To do so, please run the following command as root:
rcmysql restart

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus