Novell is now a part of Micro Focus

Security update for CVS

Knowledgebase

(Last modified: 04MAY2004)


solutions Security update for CVS SuSE Linux Maintenance Web (301825b2494a65fe3dc6517c2bcd08ba)

Applies to

Package: cvs
Product(s): SUSE LINUX Retail Solution 8

Release: 20040504
Obsoletes: none

Indications

Everyone using CVS pserver should update.

Contraindications

None.

Problem description

Malformed "Is-modified" and "Unchanged" tags could be used by remote attackers
to execute arbitrary code on CVS pservers.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh cvs.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus