Queue Based Printers no longer servicing Queues after upgrade to eDirectory 8.7

(Last modified: 25Mar2004)

This document (10078052) is provided subject to the disclaimer at the end of this document.

fact

Novell NetWare 6.0

Novell NetWare 5.1

Novell eDirectory 8.7 for NetWare 5.1

Novell eDirectory 8.7 for NetWare 6

Novell Queue Based Printing

symptom

Queue Based  Printers no longer servicing Queues after upgrade to eDirectory 8.7

Print Servers no longer attach to the NetWare server.

Print servers unable to connect to file server

JetDirect not connecting to NetWare 5.1 or NetWare 6 server.

Lexmark Optra won't attach to NetWare 5.x or NetWare 6.x server

Queue based printing no longer appears to work on servers upgraded to eDirectory 8.7

Printers not working after NetWare or eDirectory update.

cause

After upgrading to eDirectory 8.7, some customers have reported that bindery Print Servers were no longer servicing their queues. The cause of this is that the firmware on the printers could not handle the amount of data being returned from the Get Server Address request. eDirectory 8.7.x has introduced new features that require additional address to be stored in the netwwork address attribute that is used by the Get Server Address request. New features such as eMBox and iMonitor create several URL addresses in the Network Address field for the servers. When the Print servers authenticates, a create service connection request is made that begins the authentication process by performing  a Get Server Address request. Most printers have a hardcoded buffer size for the server address.  If the firmware on the printer has a smaller buffer size allocated than the actual size that is sent, the authentication will fail.

fix

There are no current plans to remedy this from eDirectory.  The reason for this would be that the only way to fix this would be to eliminate new features that require additional addresses.  Therefore, the fix for this is issue is to upgrade the firmware for the printers if it is available for that printer.  Most printer companies have published newer firmware versions that will handle the additional buffer size.  Contact your printer firmware provider for more information on how to obtain the firmware.

If newer firmware is not available, the administrator can disable eDirectory features and or other referrals to decrease the size of the referral list.  Below are some ways to reduce the referral size.  The recommendation is to execute the following in order, testing printing after each step.  If printing starts to work, additional actions are not necessary.

1. Implement NDPS and point your ques to the NDPS object which uses push technology rather than pull.  This results in a different authentication method that eliminates the need for the print server client to get a referral list.

2. Disable NCP over UDP (set this in monitor on a Netware server).  This will remove any UDP addresses from the referral list.  This will not affect eDirectory because eDirectory does not support authentication over UDP.

3. Unload embox.nlm.  This will eliminate several addresses from the address list.  embox is a new utility that allows eDirectory administration from a web browser or java client (ie iManager uses embox to administer eDirectory through the eDirectory administration roles).  This will disable this feature but there are stand alone tools on the server (ie DSREPAIR.NLM and ConsoleOne that will perform the same actions).  Hot Continuous backup will also be disabled if embox is unloaded.

4. Unload NDSimon, Portal and httstk.  This will obviously disable Novell Remote Manager and NDS iMonitor but will also eliminate adddress out of the network address attribute.

note

The above workarounds will eliminate addresses out of the referral list.  However, the affect may not be immediate.  To speed up to process of removing the addresses, run a dstrace with a *l (i.e. set dstrace=*l) to trigger a limber which will modify the network address attribute.

Known Printers with firmware issues:

Lexmark.  Problem is fixed with Lexmark firmware dated July 14, 2003 or later.  

Xerox (firmware version unknown at this point)

Jet-Direct - Anything older than version 8.40 will probably have the issue.

fix

For additional information on eDirectory 8.7, please see the following solution.  NOVL81742 - eDirectory 8.7 Readme Addendum 

document

Document Title: Queue Based Printers no longer servicing Queues after upgrade to eDirectory 8.7
Document ID: 10078052
Solution ID: NOVL85178
Creation Date: 20Dec2002
Modified Date: 25Mar2004
Novell Product Class:NetWare
Novell eDirectory

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