JClient Exception when logging into iManager 1.5 on Linux

(Last modified: 20Dec2002)

This document (10077278) is provided subject to the disclaimer at the end of this document.

fact

Novell iManager 1.5

Novell eDirectory 8.7 for Linux

RedHat Linux 7.3

RedHat Linux 7.2

symptom

JClient Exception when logging into iManager 1.5 on Linux

Cannot login to iManager on Linux

cause

The JClient Java Classes are not in the proper library path.

fix

Add  /usr/lib to the $LD_LIBRARY_PATH variable and export it.

There are many places to set environment variables in UNIX based systems.  Listed below is just one way to set this variable.

1.  Stop Tomcat. This can be done by issuing the following: $TOMCAT_HOME/bin/tomcat.sh stop

2. Open  $TOMCAT_HOME/bin/tomcat.sh in an editor that you are familiar with using.  Add the following after "#!/bin/sh":

LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH

3. Save the file and start Tomcat. This can be done by issuing the following: $TOMCAT_HOME/bin/tomcat.sh start

4.  You should now be able to login to iManager.

For additional information on eDirectory 8.7, please see the following solution.  NOVL81742  - eDirectory 8.7 Readme Addendum

document

Document Title: JClient Exception when logging into iManager 1.5 on Linux
Document ID: 10077278
Solution ID: NOVL84402
Creation Date: 02Dec2002
Modified Date: 20Dec2002
Novell Product Class:Beta
Novell eDirectory

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