Novell Home

CVE-2014-2299

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-2299 at MITRE

Description

Buffer overflow in the mpeg_read function in wiretap/mpeg.c in the MPEG parser in Wireshark 1.8.x before 1.8.13 and 1.10.x before 1.10.6 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a large record in MPEG data.

NVD CVSS v2 Base Score: 9.3 (AV:N/AC:M/Au:N/C:C/I:C/A:C)

Novell/SUSE information

Novell Bugzilla entry: 867485

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SLE 11 SP3 DEBUGINFO
  • wireshark-debuginfo >= 1.8.13-0.5.1
  • wireshark-debugsource >= 1.8.13-0.5.1
Builds
SAT Patch Nr: 9060
SUSE Linux Enterprise Software Development Kit 11 SP3
  • wireshark >= 1.8.13-0.5.1
  • wireshark-devel >= 1.8.13-0.5.1
Builds
SAT Patch Nr: 9060
SUSE Linux Enterprise Software Development Kit 11 SP3
  • wireshark-devel >= 1.8.13-0.5.1
Builds
SAT Patch Nr: 9060
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • wireshark >= 1.8.13-0.5.1
Builds
SAT Patch Nr: 9060
SUSE Linux Enterprise Server 11 SP1
  • wireshark-debuginfo >= 1.8.13-0.5.1
Builds
SAT Patch Nr: 9059

© 2014 Novell