Novell Home

CVE-2014-2285

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-2285 at MITRE

Description

The perl_trapd_handler function in perl/TrapReceiver/TrapReceiver.xs in Net-SNMP 5.7.3.pre3 and earlier, when using certain Perl versions, allows remote attackers to cause a denial of service (snmptrapd crash) via an empty community string in an SNMP trap, which triggers a NULL pointer dereference within the newSVpv function in Perl.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entries: 866942, 875217

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • net-snmp-devel >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9015
SUSE Linux Enterprise Software Development Kit 11 SP3
  • net-snmp-devel >= 5.4.2.1-8.12.20.1
  • net-snmp-devel-32bit >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9015
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libsnmp15-32bit >= 5.4.2.1-8.12.20.1
  • net-snmp-devel >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9015
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libsnmp15 >= 5.4.2.1-8.12.20.1
  • net-snmp >= 5.4.2.1-8.12.20.1
  • perl-SNMP >= 5.4.2.1-8.12.20.1
  • snmp-mibs >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9015
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libsnmp15 >= 5.4.2.1-8.12.20.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.20.1
  • net-snmp >= 5.4.2.1-8.12.20.1
  • perl-SNMP >= 5.4.2.1-8.12.20.1
  • snmp-mibs >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9015
SUSE Linux Enterprise Server 11 SP3
  • libsnmp15 >= 5.4.2.1-8.12.20.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.20.1
  • net-snmp >= 5.4.2.1-8.12.20.1
  • perl-SNMP >= 5.4.2.1-8.12.20.1
  • snmp-mibs >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9015
SUSE Linux Enterprise Server 11 SP1
  • net-snmp-debuginfo >= 5.4.2.1-8.12.20.1
Builds
SAT Patch Nr: 9014

© 2014 Novell