LPR Communication Failed
(Last modified: 11Oct2005)
This document (10099192) is provided subject to the disclaimer at the end of this document.
fact
Novell Distributed Print Services (NDPS)
Novell iPrint
symptom
LPR Communication Failed
Printer Agent Status and Control: Needs Attention
Printer Agent Status Details: LPR Communication Failed
cause
Some printer hardware does not support LPR communication, or port 515 is disabled by default
fix
Set up the printer to print via port 9100 via one of the following:
- Open iManager and select "Create Printer" under the iPrint Role
- Enter the name of the printer and select the appropriate manager
- Enter the IP address of the printer, and select port 9100 rather than LPR Printer Name: PASSTHROUGH
- Select appropriate drivers (if available) and click finish
or
If this option is not available, this can be done manually via the following steps:
- At the server console, switch to the NDPS Manager screen
- Select Printer Agent List
- Select the Printer Agent in question from the Printer Agent List.
- Select Information
- Select Gateway Status
- Push the "Insert" key
- Change the Gateway Autoload Command to the following: "NDPSGW PORT=RAW HOSTADDRESS=X.X.X.X"
- Restart the Printer Agent
note
A printer can be tested to see if it supports LPR communication by doing the following:
In Windows:
- Click on Start -> Run
- Key: cmd and hit Enter
- At the command prompt screen, key: telnet X.X.X.X 515 (where X = IP address of the printer in question)
- If a blinking cursor or no error appears, port 515 is open
- If a "Connection Refused" or "Connection failed" error returns, that printer either does not support LPR communication, or it is not enabled
In Linux:
- Open a Terminal
- Key: telnet X.X.X.X 515 (where X = IP address of the printer in question)
- If a message of "Connected to X.X.X.X" appears, port 515 is open
- If it returns "Trying to connect to IP" and hangs, the port is not open
Printing through port 9100 is available with NDPSGW.NLM version 3.01 dated May 5, 2004 and later
The ability to create a printer in iManager using port 9100 is available with NetWare 6.5 SP 2 and later
document
Document Title: | LPR Communication Failed |
Document ID: | 10099192 |
Solution ID: | NOVL103756 |
Creation Date: | 05Oct2005 |
Modified Date: | 11Oct2005 |
Novell Product Class: | Novell Printing Services |
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