Log files corrupted with ASCII NULL (00) characters
(Last modified: 04Apr2006)
This document (10092434) is provided subject to the disclaimer at the end of this document.
fact
Novell Volera Excelerator 2.x
TTS enabled for proxy in PXYINFO.CFG
symptom
Log files corrupted with ASCII NULL (00) characters
cause
Appears to be a bug in the proxy TTS-enabling code
fix
Submitted to Engineering. Under investigation.
note
Log file corruption was found in all log files recorded when TTS is enabled in pxyinfo.cfg for a reverse proxy service. It is likely that this would also happen in forward/transparent mode. Disabling TTS in pxyinfo.cfg prevents the corruption from occurring.
All instances of corruption seem to appear at 4k (4096) offsets into the log files.
It is worth noting that after each instance of corruption, the corruption ends with the beginning of a perfectly formatted log entry. In other words, the corruption appears to begin in the middle of a log entry, overwriting data with ASCII 00 (NULL) characters. At the end of the NULL characters, a normal log entry begins.
To view the corruption, use vi, GVim (windows vi port) or a hex editor. In the hex editor, searching for 00 00 00 00 00 00 00 00 will quickly display the problem areas in the log file.
NOTE: when viewed with a standard text editor, the corruption will appear as a simple truncation of the line. It's much easier to see in either GVim / vi or a hex editor.
document
Document Title: | Log files corrupted with ASCII NULL (00) characters |
Document ID: | 10092434 |
Solution ID: | NOVL96529 |
Creation Date: | 13Apr2004 |
Modified Date: | 04Apr2006 |
Novell Product Class: | Volera Excelerator |
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