iPrint problems in a ZENworks environment

(Last modified: 26Jan2004)

This document (10090597) is provided subject to the disclaimer at the end of this document.

fact

Novell iPrint

Novell NetWare 6.5 Support Pack 1

Novell ZENworks for Desktops 4 - ZFD4

goal

iPrint problems in a ZENworks environment

symptom

Printers no longer use the short printer name.

Rollout of printers is no longer "silent."

cause

The service pack overwrites the iPrint.ini file with the defaults. This changes the configuration of the printers back to the default. ie the printer short name reverted to the long name.

fix

Salvage the old iPrint.ini file.

symptom

ZENworks Policies don't push out printers.

cause

iPrint version 2.02 uses a new registry setting that older versions ignored. The user incorrectly had a proxy setting in the iPrint Policy of Zenworks, believing that the URL requested was the URL for the iPrint Web Server. In fact, this parameter should be used ONLY in a policy for users that require going through a proxy server to access iPrint. This parmeter was causing the new version of iPrint not to roll out.

Analyzing the contents of an ipptrace.txt file (For instructions on how to capture an ipptrace.txt file, see TID 10064594), we see something similar to the following lines:

[Joe User][thrd=000006D4][    343934ms][NIPPLIB] - ======== HTTPSendSimplePost ========
[Joe User][thrd=000006D4][    343934ms][NIPPLIB] - IppGenLangString (http://server1.nts.provo.novell.com:631/ipp/Lexmark 84D123)

To find the offending line, search for "HTTPSendSimplePost" in the ipptrace.txt file.

The problem lies with the full path being specified to the ipp server. This path, being read from the "HKCU\printers\proxy server ZEN URI" key, is prepended to the name of the printer, so if the full path is specified, an invalid name results. This key is set by ZENworks after the administrator configures ZENworks for an internet server. This key should be cleaned up (cleared) by ZENworks as soon as it has been used, but it is not being cleared, and iprint (nipp) continues to use this key in preference to the "HKCU\printers\proxy server URI" key which it would otherwise use, if a proxy server were specified in the Ipp client.

fix

Removing the parmeter from the Zen Policy and remove the entry in the "HKCU\printers\proxy server ZEN URI" key.

note

The ZENworks ConsoleOne snapin for the Novell iPrint Policy (displayed below) never mentions "proxy server."  Instead, it refers to "Internet-accessible Address for Printing." This
can cause confusion resulting in the problem described in this document. Do not set this value unless you are utilizing a proxy server to access iPrint..

 

document

Document Title: iPrint problems in a ZENworks environment
Document ID: 10090597
Solution ID: NOVL95022
Creation Date: 23Jan2004
Modified Date: 26Jan2004
Novell Product Class:Management Products
NetWare

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