"Tree or server not found" error on bootup and immediate login
(Last modified: 30Mar2004)
This document (10086186) is provided subject to the disclaimer at the end of this document.
fact
Novell Client v4.9 for Windows NT/2000/XP.
symptom
"Tree or server not found" error on bootup and immediate login
The selected tree cannot be found. Error code: 880f
timing issue with startup, when immediatly hitting ctrl-alt-del when it is first displayed and then going to advanced and hitting the tree browse button can show the problem of no trees available. if you wait15 to 45 seconds before doing this process then the trees are available.
This also occurs when the customer's workstation has the local security setting / interactive logon: do not require Ctrl+Alt+Del enabled. Customer's workstation gets IP addr via DHCP incl DNS, and SLP DA infos. When the customer hits enter immediately when NWGINA pops up (and the user has a password assigned) the customer gets the error message. He then waits 15 secs or so and does the same thing again and then he gets the correct error msg: wrong password. The workstation is not PINGable from another maschine when NWGINA pops up - only about 10 secs later, indicating that NWGINA should not come up until IP is ready on the WS.
cause
The cause is that there is a default number of retries and that certain services are not able to get loaded and queried before the default retries have timed out.
fix
Some instances of this problem are resolved by using the DependOnService registry setting. If the Client loads before the SLP service is running, resources which cannot be found as a result of this condition may be added to the bad server cache, resulting in "tree or server cannot be found" type errors. This setting ensures that the SLP service is loaded and running before the Novell Client attempts to load.
For Windows 2000, XP:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetwareWorkstation]
"DependOnService"=hex(7):53,00,52,00,56,00,4c,00,4f,00,43,00,00,00,00,00
For Windows NT4:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetwareWorkstation]
"DependOnService"=hex(7):53,52,56,4c,4f,43,00,00
Fixed in the Novell Client v4.9 SP1 for Windows NT/2000/XP.
Fixed in the Novell Client 4.83 SP3 for Windows NT/2000/XP
The problem is fixed with 3 new client files and 3 new client registry settings dealing with these pieces. nwfs.sys (see nwfs parameter registry key below). "Check SRVLOC Loaded Retries" was added to control new logic that verifies that srvloc.sys is loaded. The number of retries with a 1 second delay is specified by this parameter. The default is 5. Whenever a NWC_GET_REQUESTER_LINK_STATUS IOCTL is received by nwfs.sys it will first check for srvloc.sys being loaded. If "Check SRVLOC Loaded Retries" is set to 0, no attempts will be made to check if srvloc.sys is loaded. Good status is always returned after all retries even if srvloc.sys is not loaded. There is no upper limit enforced for this registry parameter. Again this should not be greater than 20. srvloc.sys nwfs.sys requests from Srvloc.sys to see at least one active DA exists. whenever a NWC_GET_REQUESTER_LINK_STATUS IOCTL is received by nwfs. A new srvloc.sys parameter, "Check For Active DA Retries" has been added to control the number of retries with a one second delay for the active DA check. If this parameter is set to 0 no attempts will be made to check for an active DA and good status will still be returned. In any case after the specified retries good status will be returned. This has a default of 0 and if not present in the registry, no attempt will be made to verify that an active DA exists. In environments with no DAs, this parameter must be 0 since severe performance problems will occur. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SRVLOC\Parameters] In some cases these settings had to be set to 15 or 20 retries to get the results needed. Be aware that the higher you set these settings the longer it will take to timeout when not connected to the network.
"Max Retries"=dword:00000007
"Check SRVLOC Loaded Retries"=dword:00000006
"Check For Active DA Retries"=dword:00000007
In order for these parameters to work newer versions of the LOGINW32.DLL, NWFS.SYS, and SRVLOC.SYS files is required.
document
Document Title: | "Tree or server not found" error on bootup and immediate login |
Document ID: | 10086186 |
Solution ID: | NOVL91826 |
Creation Date: | 15Aug2003 |
Modified Date: | 30Mar2004 |
Novell Product Class: | NetWare |
disclaimer
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.