iManager fails to work after installing on Windows 2000 server.

(Last modified: 10Jul2003)

This document (10084919) is provided subject to the disclaimer at the end of this document.

fact

Novell iManager 1.5.1

Novell iManager 1.5.2

Novell iManager 1.5

Novell eDirectory 8.7 for Windows 2000

Novell eDirectory 8.7 for Windows NT

Windows 2000 server installed with out IIS web server or IIS has been removed.

eDirectory 8.7 installed on to Windows 2000 server.

symptom

iManager fails to work after installing on Windows 2000 server.

iManager 1.5.1 will not work after installing on Windows 2000 server with no IIS running and eDirectory installed.

iManager 1.5.2 will not work after installing on Windows 2000 server with no IIS running and eDirectory installed.

Error: "Page cannot be found"

cause

There is an issue with iManager 1.5.1 and 1.5.2 when installing on Windows 2000.  The problem only occurs when Windows 2000 is running without IIS and eDirectory is installed on the Windows server.  By default the HTTPSTK that is used by eDirectory for NDSiMonitor will try to capture ports 80 (non-secure) and 443 (secure) first.  If ports 80 and 443 are not available the HTTPSTK will attempt to bind to 8008 and 8009 and up until it finds available ports.  Because there is no web server (IIS) running HTTPSTK captures ports 80 and 443.

When the iManager 1.5.1 or 1.5.2 installation runs it will detect the absence of the IIS web server and attempt to install an Apache web server.  The installation detects that port 80 and 443 are in use and the will say it is going to install Apache at port 8000.  However, there is an issue with the Apache web server installation when it cannot use ports 80 and 443.  In this case the Apache install will not complete properly.  No errors are given however the Apache configuration files are configured for ports 80 and 443 (not 8000) and the Apache Windows service is not installed. 

The results of the Apache installation not working is that the iManager login page will not load.  This is because the Apache service is not running and the Apache configuration files are configured to use ports 80 and 443.  If the Apache service is manually executed it will not work because the eDirectory HTTPSTK is already using port 80 and 443.

Here is a summary of the issue.
-Install Window 2000 server with no IIS web server.
-Install eDirirectory 8.7 with current patches. The eDirectory HTTPSTK is using ports 80 and 443 for NDSiMonitor.
-Install iManager 1.5.2 (or 1.5.1). When done Apache is not installed as a service and is not running and the iManager login page will not load.

fix

The following procedure can be done to work around this issue BEFORE installing iManager.

1. Before installing iManager, shut down the NDS Server service.
2. Install iManager 1.5.2 then go to the URL in gettingstarted.html (example URL https://1.1.1.1/eMFrame/iManager.html) to verify that the iManager login page can be accessed.  Also verify that Apache2 and Tomcat are running as a service.
3. Restart the NDS Server service.
4. Select the Transport tab and expand HTTPS and then Bound Transports.  Note the port bound for TCP (for example 8011).   
5. Stop the NDS service and then start it back up.  What this does it writes the new ports that the eDirectory HTTPSTK captured to the c:\novell\NDS\dibfiles\config.acs file.  This file is only updated when the NDS service is stopped and works in conjunction with the HTTP Server object in providing local server configuration information for eDirectory.
6. Recheck the HTTPS bound transports to make sure TCP bound to a valid port.
7. Verify that NDSiMonitor can be accessed.  For example, if the port bound for HTTPS is 8011 and the server IP address is 1.1.1.1 the URL to access NDSiMonitor would be https://1.1.1.1:8011/nds.

If iManager 1.5.1 or 1.5.2 has been installed in this configuration and the problem with the Apache installation has occurred follow these steps to resolve the issue.

1. Uninstall the Apache/Tomcat program using Windows Add/Remove programs.
2. Uninstall iManager using Windows Add/Remove programs.
3. Delete left over files in the c:\Program Files\Novell\Tomcat\ directory.
4. Shut down the NDS eDirectory service.  This prevents the eDirectory HTTPSTK from capturing ports 80 and 443.
5. Reinstall iManager 1.5.x.  The Apache service will install properly and use ports 80 and 443.

note

Note on port usage: In this example the eDirectory HTTP transport bound to 8008 and the HTTPS transport bound to 8011.  As noted above the eDirectory HTTPSTK with attempt to bind to ports 8008 and 8009 after trying 80 and 443.  However in this example configuration Tomcat will take port 8009.  This means eDirectory will then use the next available HTTPS port which in this case is 8011.

document

Document Title: iManager fails to work after installing on Windows 2000 server.
Document ID: 10084919
Solution ID: NOVL90938
Creation Date: 10Jul2003
Modified Date: 10Jul2003
Novell Product Class:Management Products
Novell eDirectory

disclaimer

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