Error: 820E on USERxyz.DB or Msg.db on POA.
(Last modified: 01Jun2004)
This document (10077933) is provided subject to the disclaimer at the end of this document.
fact
Novell GroupWise 6.5
Novell GroupWise 6
Novell GroupWise 5.5 Enhancement Pack
symptom
Error: 820E on USERxyz.DB or Msg.db on POA.
Error: "820E" on Client.
Error: "The database facility reported error [820E] on userxyz.db"
Error: File lock error [820E] User:UserName
Client unresponsive after sending a mail for owner of USERxyz.DB
Client displays "Sending: <mail subject>" for a long time in the status bar.
Server goes to 100% utilization in TCP_Handler thread.
HTTP interface of POA shows that the TCP_Handler thread stuck on action "Read Index".
fix
The hard disk that the Post Office was installed on was degenerating over time causing more and more 820E errors. Replacing the hard disk solved the errors.
cause
An 820E error means that a process is locking the database in question - this is not always a bad error as databases can be locked for valid reasons such as GWCheck runs or mail delivery. Normally the POA will defer whatever action is was attempting and try again after a short period of time. If the 820E error persists on a particular database then troubleshooting steps need to be taken to find out what process is locking the file and why. Very often it can be server or client based virus scanners or a database rebuild in progress.
fix
Unloading Virus and or backup software has also been noted to resolve 820E errors.
Make sure your Post Office links in the properties of the GWIA and/or WebAccess objects are Client/Server only.
cause
The GroupWise clients are connecting via Direct. This can cause database corruption and lock the databases.
fix
Make sure your Post Office object is setup for Client/Server only for the clients.
If the above suggestions do not resolve the problem the problem may be related to using out dated GroupWise Clients. Make sure all users are using current versions of the GroupWise Client. You can verify this if you have HTTP to the POA setup. Under the Status column click on C/S Users which will show each user currently logged in and the version of the GroupWise Client. It will not report the client version if the client is older than Enhancement Pack SP2.
cause
Corruption in database
fix
Using GWcheck run a structural rebuild on the specific database. Follow this process with a structure, index, contents and fix problems
document
Document Title: | Error: 820E on USERxyz.DB or Msg.db on POA. |
Document ID: | 10077933 |
Solution ID: | NOVL84846 |
Creation Date: | 18Dec2002 |
Modified Date: | 01Jun2004 |
Novell Product Class: | Groupware |
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