How to diagnose problems using the CMSynergy engine startup daemon (ESD)

(Last modified: 05May2004)

This document (10077489) is provided subject to the disclaimer at the end of this document.

goal

How to diagnose problems using the CMSynergy engine startup daemon (ESD)

symptom

No ESD found on host

cause

Check that esd is actually running on the server (ccmesd in the process list) and if not start it with ccm_esd as ccm_root

goal

Debugging the CMSynergy engine startup daemon (ESD)

fact

Telelogic CMSynergy

symptom

ERROR: "UISSYS engine daemon not registered with router at host hostname"

fix

When engine_daemon is TRUE in the client ccm.ini file, the engine host must be specifed with no domain. For example, the user must enter cm0, not cm0.provo.novell.com. Also, the engine host must contain only lower-case letters.

symptom

ERROR: "ESD error: open failure on eng log <bad_path/ccm_eng.log>"  (This message is in $CCM_HOME/log/ccm_esd_server_name.log on the server)

fix

When engine_daemon is TRUE in the client ccm.ini file, the client must not set the CCM_ENGLOG variable. The engine log files are stored under $CCM_HOME/log/esd on the server.

note

The log files under $CCM_HOME/log/esd (on the Synergy servers) are an excellent way of diagnosing several common problems.

1) If $CCM_HOME/log/esd/ccmeng_xyz.log does not exist, then one of the following is probably true:
    a) xyz does not have engine_daemon = TRUE in the ccm.ini file
    b) xyz has edited the wrong ccm.ini file
    c) xyz cannot connect to the server (DNS setup problems)
    d) xyz has set the CCM_ENGLOG variable

2) If the user's log file contains the following, then either the user does not exist (in /etc/passwd or eDir) or the user is using the wrong password:
    PAM error invoking pam_authenticate: 'Authentication failed'
    sent failure message: Unable to validate the password.  User name or password is incorrect.
    ESD: process terminating -194

3) If the log file contains the following, then the user is attempting to log into the /dbs2/nds database (this is good for finding out problems with database paths):
    Opened Continuus/CM Release 6.2 db /dbs2/nds dbname //cm0c/nds.

document

Document Title: How to diagnose problems using the CMSynergy engine startup daemon (ESD)
Document ID: 10077489
Solution ID: NOVL84544
Creation Date: 06Dec2002
Modified Date: 05May2004
Novell Product Class:Third Party

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