During login process, almost all login script items generate errors
(Last modified: 20Jan2003)
This document (10072715) is provided subject to the disclaimer at the end of this document.
fact
Microsoft Windows 2000 SP2
Zenworks for Desktops 3.2
zf32ptk.exe
Client 4.8 for Windows NT/2000
Novell Client 4.83 for Windows NT/2000 with the NT483PT1 patch
Novell ZENworks for Desktops 3.x
Novell Zenworks for Desktops 2.0
Novell ZENworks for Desktops 1.1 SP3
Summary of configuration: NDS user-id is associated to a Windows 2000 Policy Package. Dynamic Local User is set to include User group only Roaming profiles are enabled
symptom
During login process, almost all login script items generate errors
Explorer.exe generates an error and restarts, and the User hive of the
Programs (GroupWise, etc) won't run due to incomplete HKCU hive.
Error occurs when the application is being distributed by NAL
Error: "Could not configure workstation for application [ .application.context ] (id=-15)"
Error: "Unable to create rollback files. (D015)"
cause
Registry appears to have not completely loaded.
fix
1: Have a complete backup (image backup recommend) of the Windows 2000 desktop. IN this example we call the "transfer PC". 2: Make sure the file server where the User's Windows 2000 profile is backed up, in case a copy fails or you make an unintended deletion. 3: Make sure the affected user is not logged in ANYWHERE on the network (otherwise the fix would be overwritten when the user finally logs out) 4: Make sure no admin has any files or Explorer windows open from the affected user's home directory. Otherwise you will not be able to apply the fix. 5: Login as a different user (ie, Admin) to the "transfer PC". 6: Locate the Profiles directory on the transfer PC. For a clean Windows (2000 install, the default is "C:\Documents and Settings") 7 This is from the Microsoft documentation: Locate the "Default User" folder and make a backup copy to "Default User.bak" Delete all the files and folders WITHIN the "Default User" folder. (ie Application Data, Cookies, Desktop, etc) Copy the CONTENTS of the affected users "Windows NT 5.0 Workstation Profile" into the "Default User" folder. For this example, the affected user's roaming profile is stored in: f:\home\user\Windows NT 5.0 Workstation Profile" The Default User folder should now contain about 8 folders (Application Data, Cookies, Desktop, etc) and about 3 files (ntuser.dat, ntuser.ini, ntuser.dat.log) DELETE the affected user's roaming profile from the network, ie in this example you would delete: f:\home\user\Windows NT 5.0 Workstation Profile" 9: Logout as the administrator from the transfer PC. 10: Login to the transfer PC as the affected user. Windows automatically copies the profile from the "Default User" folder, since no roaming profile is found. 11: Logout as the affected user. 12: Login to the transfer PC as the Administrator. Delete the current "Default User" folder. Rename "Default User.bak" to "Default User".
note
You should now be able to see that the users roaming profile (ie f:\home\user\Windows NT 5.0 Workstation Profile) has been re-installed.
document
Document Title: | During login process, almost all login script items generate errors |
Document ID: | 10072715 |
Solution ID: | NOVL81007 |
Creation Date: | 19Jul2002 |
Modified Date: | 20Jan2003 |
Novell Product Class: | Management Products |
disclaimer
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.