Error: "Application Explorer Status: Problem: Install Failed.MSI returned error code: 1624"
(Last modified: 20Feb2005)
This document (10066429) is provided subject to the disclaimer at the end of this document.
fact
Novell ZENworks for Desktops 3.2
Novell ZENworks for Desktops 3.0
Novell ZENworks for Desktops 4 - ZFD4
Novell Application Management
Disconnected NAL
symptom
Error: "Application Explorer Status: Problem: Install Failed.MSI returned error code: 1624"
Force Cached Disconnected MSI Applications will not launch when using an MST Transform File
Disconnected MSI Applications running from a ZENworks Virtual CD will not launch when using an MST Transform File
Error occurs when running the application in disconnected mode
cause
The NAL call to the Windows Installer refers to the MST Transform file on the original network path (which is not available in disconnected mode)
This can be seen in the NAL MSI log ZAPPMSI.LOG
fix
Fixed in files available for ZfD 3.0 customers in the patch ZD3NAL7A.EXE
Fixed in files available for ZfD3.2 customers in the following patches - ZD32NW4.EXE, ZD32NW.EXE, ZD322K1.EXE, OR ZD322K2.EXE (all are the same patch for different OS)
Fixed in ZENLITE.DLL dated 9/26/02 or later for ZfD4 customers, located in ZfDAGENT.MSI dated 1/24/2003 or later.
Workaround - store the MST in the same directory as the MSI, and then do not define a path when defining the MST, just reference the filename.
document
| Document Title: | Error: "Application Explorer Status: Problem: Install Failed.MSI returned error code: 1624" |
| Document ID: | 10066429 |
| Solution ID: | NOVL64789 |
| Creation Date: | 28Nov2001 |
| Modified Date: | 20Feb2005 |
| Novell Product Class: | Management Products |
disclaimer
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.