Troubleshooting Application Reporting in ZfD 3

(Last modified: 07May2002)

This document (10057067) is provided subject to the disclaimer at the end of this document.

goal

Troubleshooting Application Reporting in ZfD 3

fact

Novell ZENworks for Desktops 3.0

symptom

Database and SNMP reporting not working.

Running reports generates the following error:  
"An error prevented report generation.  Possible causes include an invalid SQL query, lack of an odbc driver, or an incorrect data source name."

cause

Service Location Package not in effect.

ODBC Driver Information might be incorrect.

fix

Make sure Service Location Package is associated to user's container.

Verify info on ODBC Driver Information tab of ZfD 3 database object is entered correctly.  With Support Pack 1 (SP1), it will default to Sybase if the tab is left blank, but for the initial release, the correct ODBC driver info must be entered.

symptom

How can I view the SNMP traps?

fix

To see the traps, you need an SNMP manager running on the trap target, like ManageWise console.

symptom

Can I purge the NAL.DB?

fix

The NAL.DB cannot be purged, but you can rename NAL.DB, and then re-install Sybase using the ZfD 3 Installation program to create a new NAL.DB.

Tip:  When Sybase is first installed, make a backup copy of NAL.DB so you always have a new, empty NAL.DB to use.  

Configuring Application Reporting
See How to configure Application Reporting in ZfD 3 for more information.

For additional information, visit the online documentation for ZENworks for Desktops 3:
http://www.novell.com/documentation/lg/zfd3/docui/index.html

document

Document Title: Troubleshooting Application Reporting in ZfD 3
Document ID: 10057067
Solution ID: NOVL26942
Creation Date: 21Sep2000
Modified Date: 07May2002
Novell Product Class:Management Products
NetWare

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.