User is prompted to login to WebAccess multiple times
(Last modified: 18Apr2003)
This document (10051758) is provided subject to the disclaimer at the end of this document.
fact
Novell GroupWise 6
Novell GroupWise 5.5 EP Support Pack 1
Novell GroupWise 5.5
Novell GroupWise WebAccess
Novell BorderManager 3.5
HTTP Proxy
HTTP Acceleration
Proxy Server
symptom
User is prompted to login to WebAccess multiple times
Error: "Your login is not current. Please log in again"
User keeps getting asked to authenticate while trying to access email through WebAccess
cause
When doing reverse HTTP Proxy or HTTP Acceleration with BorderManager on GroupWise WebAccess it causes the user to have to login twice. Once to render the cached session invalid and once to login.
fix
Workaround is to not accelerate WebAccess. This issue has been reported to development.
cause
Another possible cause is a proxy cache problem with the proxy server. (It may or may not be BorderManager)
fix
Fix the proxy problem with the firewall vendor.
cause
Transparent Proxy for BorderManager, BorderManager Access Control Rules and an internal Webserver can have this problem.
fix
1. Goto the details of the BorderManager server object in NWAdmin.
2. Select the BorderManager Setup tab | Transparent Proxy | Exception IP Address List.
3. Put in the IP address to the Webserver.
cause
WebAccess uses the client IP address as added security to help verify session requests. Since many proxies are setup with multiple proxy servers to help with load balancing, it is common occurrence for a WebAccess user's session to originate from one proxy server and a later request during the same WebAccess session to be routed through a different proxy server. This will cause WebAccess to force the user to re-authenticate. An option in the WEBACC.CFG file determines whether the client's IP address is used to validate the user session. With Enhancement Pack SP1, this setting can now be configured by the administrator. The default is to require the IP Address validation.
fix
To disable WebAccess IP Address validation, change the value of the "Security.UseClientIP.enable" setting in the WEBACC.CFG file from "true" to "false" (as in the following example): Security.UseClientIP.enable=false.
document
Document Title: | User is prompted to login to WebAccess multiple times |
Document ID: | 10051758 |
Solution ID: | NOVL5959 |
Creation Date: | 12Apr2000 |
Modified Date: | 18Apr2003 |
Novell Product Class: | Groupware NetWare Novonyx |
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