Authentication or printing issues after administering NDS from a Novell 3.2 or 4.7 client.

(Last modified: 12Jun2003)

This document (10025609) is provided subject to the disclaimer at the end of this document.

fact

Novell Client 4.7 for Windows NT/2000

Novell Client 3.2 for Windows 95/98

Novell NetWare Client for MacOS 5.11

Prosoft NetWare Client for MacOS 5.13

Microsoft Client Service for NetWare (CSNW)

Microsoft Gateway Service for NetWare (GSNW)

Microsoft Client for NetWare Networks

Microsoft Service for NetWare Directory Services (MSNDS)

Hewlett Packard JetDirect print server

HP Jet Admin

HP firmware is 8.20

symptom

Authentication or printing issues after administering NDS from a Novell 3.2 or 4.7 client.

JetDirect print server unable to logon and authenticate in queue server mode.

NDS Mode has problem

Bindery Mode is okay

Problems accessing print servers created with the Novell Client 4.7 for Windows NT/2000 and the Novell Client 3.2 for Windows 95/98.

Error: "Connection status:  0x27 cannot login."

Error: "Unable to login 2B."

Unable to login with user object created by Novell Client 3.2 for Windows 95/98 or Novell Client 4.7 for Windows NT/2000.

Unable to login with user object whose password was set from a workstation running Novell Client 3.2 for Windows 95/98 or Novell Client 4.7 for Windows NT/2000.

Objects created in NWADMIN with a Windows NT 4.7 client cannot be seen by a Windows 95 client.

Objects imported in NWADMIN with a Windows NT 4.7 client cannot be seen by a Windows 95 client.

Tree icon on Macintosh platforms remains gray after login.

Macintosh client crashes the finder with a type 1 error.

Macintosh client gets chooser error "finder unexpectedly quit" message and the computer must be restarted.

Workstations running Microsoft NetWare-compatible client (GSNW, CSNW, Microsoft Client for NetWare Networks, Microsoft Service for NetWare Directory Services, MSNDS) unable to login with user account created or password set from 3.2 or 4.7 client.

Error: "You cannot be authenticated on <tree>(<context>) due to the following reason: The network path was not found."

Error: "You are not logged in to the directory tree <treename>."

Error: "An unexplained error occurred while your computer tried to access the network.  For more information, contact your network administrator."

Error: failed to authenticate to server <server name>, attempting to connect bindery FFFFFD88 -632 error

Printer will not logon to NDS

Error: "Printer cannot login to NDS"

Error: "Printer cannot authenticate to NDS"

Print layout shows the print server with a red exclamation point.

Print queue holds jobs

cause

There was a change in the authentication mechanisms of the 3.2 and 4.7 clients which caused issues with non-Novell clients.

fix

To resolve the problem introduced by administering NDS from a 4.7 or 3.2 client:

1. Upgrade the Novell Client 4.7 for Windows NT/2000 workstations with NWFS.SYS 03FEB2000 or later and the Novell Client 3.2 for Windows 95/98 workstations with CLIENT32.NLM 03FEB2000 or later. Visit Novell Product Updates to find the updated files. A better option is to upgrade to the Novell Client 4.83 for Windows NT/2000/XP or Novell Client 3.32 for Windows 95/98.

2. After upgrading to NWFS.SYS 03FEB2000 or CLIENT32.NLM 03FEB2000 or later and restarting the workstation where they were updated, reset the password on the affected objects.  For users experiencing problems authenticating, this will be the password on the user object in NDS.  For print server devices experiencing problems authenticating, this will be the password on the print server object in NDS.

3. For user objects, change the password to any value known to the user or simply to a blank password, and then have the actual user change the password again to a value known only to them.  This will allow clients such as the Microsoft NetWare-compatible clients to authenticate successfully using this user object.  Perform this step for each user object which is encountering the authentication problem, or every user object which is suspected to have been created or had it's password changed from a 3.2 or 4.7 client workstation.

4. For print server objects, change the print server password via NWADMN32 specifically to a value that the print server device will recognize.  (For example, JetDirect devices will recognize when a blank password has been set on the print server object.)  From NWADMN32 highlight the print server object, from the Object menu select 'Details', and from the details dialog select 'Change Password'.  (If setting a blank password, the 'Change Password' dialog the 'Old password:' field will be grayed out by default and simply leave the 'New password:' and 'Retype new password:' fields blank and press OK.  NWADMN32 will confirm that a blank password was intended, to which the response should be 'Yes'.)  Now physically power off the print server device (keeping in mind the print server device may or may not be embedded within the actual printer) and when powered back on the device should attempt to login and authenticate successfully.

5. If the above steps fail to resolve the authentication issue being experienced by users or print server devices, it may be necessary to delete and re-create the affected objects, i.e. the user object for the user having authentication issues or the print server object for the print server that is unable to login.  Re-creation and configuration of those object will then be required.  This is only if the above methods for some reason fail to resolve the issue.

note

Background:

After installing the Novell Client 3.2 for Windows 95/98 or Novell Client 4.7 for Windows NT/2000, if an NDS object which must be used for authentication is created or modified from a workstation running the 3.2 or 4.7 client there are specific clients and devices which may be unable to authenticate using those objects.

For example, if a print server device (such as an HP JetDirect, Xerox print server, etc.) is created, configured or has it's password reset from a workstation running the 3.2 or 4.7 client, the print server device may be unable to authenticate as the print server object created by the 3.2 or 4.7 clients.  Users would still be able to successfully submit jobs to the print queues, but the print server device would fail and/or report errors attempting to authenticate to NDS in order to service the waiting jobs.  JetDirect cards specifically will fail to login and/or report "2B" errors on the printer status display. Typically, the quickest way to resolve this issue is to delete and recreate the print server object with an updated 3.2 or 4.7 client, or by recreating the print server object with a client version other than 3.2 or 4.7.

For user objects, if a user object is created, modified or has it's password reset from a workstation running the 3.2 or 4.7 client, depending on the specific NetWare-compatible client used when logging in the user may be unable to authenticate with the user object created by the 3.2 or 4.7 client.  Microsoft NetWare-compatible clients will report failure to login or to locate the specified NetWare server or NDS tree.  Macintosh clients will fail to properly login and/or report errors which ultimately require a restart to resolve.  Logging in from any DOS or Windows-based Novell client (e.g. Novell Client for Windows 95/98, Novell Client for Windows NT/2000, etc.) will be successful using the same user object.

Other potential interim workarounds include using pre-3.2 and pre-4.7 clients on the workstations where user accounts and print server objects are administered from, or using DOS-mode utilities such as SETPASS.EXE, NETADMIN.EXE or PCONSOLE.EXE (as appropriate for the NetWare server version involved) to create the objects and/or reset the passwords of objects created by non-updated 3.2 & 4.7 clients that are being affected by the issue.

Another thing that can prevent communications from the NetWare server NDPS HPGATE.NLM to the HP JetDirect could be the firmware for the HP JetDirect or the HPGATE.NLM revision.

Go to the HP website at:http://www.hp.com/cposupport/eschome.html to download updated firmware/gateway.

document

Document Title: Authentication or printing issues after administering NDS from a Novell 3.2 or 4.7 client.
Document ID: 10025609
Solution ID: 1.0.51529894.2510919
Creation Date: 26Jan2000
Modified Date: 12Jun2003
Novell Product Class:NetWare
Novell BorderManager Services

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