Error: -128 running DSREPAIR
(Last modified: 08Jan2003)
This document (10025577) is provided subject to the disclaimer at the end of this document.
fact
Novell Directory Services
symptom
Error: -128 running DSREPAIR
Directory Services could not lock NDS database
cause
Sometimes when running DSREPAIR | ADVANCED OPTIONS | REPAIR LOCAL DS DATABASE, the process returns -128 DSERR_LOCK_FAIL. This occurs because a stream file (a file which holds items like login scripts and ZEN application object information) is locked open. NDS needs complete access to these files in order to run a successful DSREPAIR. Occasionally, one of these stream files is locked open, even when it is no longer being used.
fix
Clear the connection that is holding the stream file open. This can be done by several methods:
1. If using a newer Novell Client (Client32), clear all connections to the server by typing "CLEAR STATION ALL". Users should not be affected because the client will auto-reconnect to the server.
2. Dismount and remount the SYS volume on the server. This will clear the lock on the stream file that is locked open.
3. Locate the user connection that is holding the stream file open by using MONITOR to check the files each connection has open. Clear that user's connection.
document
Document Title: | Error: -128 running DSREPAIR |
Document ID: | 10025577 |
Solution ID: | 1.0.51908349.2513463 |
Creation Date: | 26Jan2000 |
Modified Date: | 08Jan2003 |
Novell Product Class: | Management Products NetWare Novell eDirectory |
disclaimer
The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.