Error Message on server "Station X (task XX) has timed out on its op-lock (type=2)"

(Last modified: 28Jun2003)

This document (10014212) is provided subject to the disclaimer at the end of this document.

fact

Novell NetWare 4.11 SFT III

Novell NetWare 5.0

Novell NetWare 4.11

Lotus Notes version R5

Microsoft Windows 95

Microsoft Windows 98

Microsoft Windows NT

Novell Client 4.7 for Windows NT/2000

Novell Client 4.71 for Windows NT/2000

Novell Client 4.8 for Windows NT/2000

Novell Client 3.1 for Windows 95/98

Novell Client 3.2 for Windows 95/98

Novell Client 3.21 for Windows 95/98

symptom

Error Message on server "Station X (task XX) has timed out on its op-lock (type=2)"

Error: "MSENGINE-4.11-0"

Error occurs on server.

High processor utilization at server.

Cannot save file to server.

File is already in use.

cause

Opportunistic locking enabled on the client workstation. Lotus Notes requires opportunistic locking. This problem has also been seen with Lotus Organizer and CCMail for Group Scheduling. The problem is caused when the same workstation first opens a file with an opportunistic lock and then opens the file again. The server considers the second open attempt to be a completely unique session and informs the client to clear it's op-lock. The client clears the lock on the wrong task. The server clears the lock but continues to inform the client that the lock is still not cleared by the first task. This continues until the op-lock timeout is exceeded and the message is displayed on the screen. In the Win95/98 client the op-lock is still working and the message is purely a cosmetic issue. In issues with the NT client we have seen high server utilization and file locking errors.                

fix

This problem is resolved with both a client and a server fix. The Windows 95/98 client fix requires the latest version of the Novell client32 (version 3.2). The server fix is a patch for the OS that you are running.

        1. Novell Client for Win95/98 version 3.2 - CLIENT32.NLM dated 21DEC1999 or later.
        2. Novell Client for Windows NT/2000 version 4.71 or 4.80 - NWFS.SYS dated 21DEC2000 (v4.71) or dated 02JAN2001 (v4.80).
        3. NetWare 5 (SP4 or better) - FILESYS.NLM dated 14DEC1999 or later.
        4. NetWare 4.11 (SP8 or better) - Occopnfx.nlm

If the application doesn't require opportunistic locking (file caching), the option may be turned off at all workstations and op-lock message will never be displayed.

Op-locking can be globally disabled on a NetWare 5.x server with the following set parameter:

SET CLIENT FILE CACHING ENABLED = OFF

To disable op-locking on the NT client goto the advanced settings in the properties of the Novell client and disable file caching.

Duplication Notes:
=================================
Problem can be duplicated by following the below steps:
        1. On Win95 workstation enable op-lock in the advanced settings of the client version 3.1.
        2. Load Lotus Notes version R5 on server as the application and data directory.
        3. Start the notes minder application to open the mail database.
        3. Start notes on the workstation and open up the mail database a second time.
        4. Wait 3 minutes and the error message will appear on the server console
               8-12-99       1:33:06 PM     MSENGINE-4.11-0
               Station 5 (task 31) has timed out on its op-lock (type=2)

document

Document Title: Error Message on server "Station X (task XX) has timed out on its op-lock (type=2)"
Document ID: 10014212
Solution ID: 4.0.21412410.2273215
Creation Date: 12Aug1999
Modified Date: 28Jun2003
Novell Product Class:NetWare

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