Troubleshooting: MPREXE Errors in Windows 95 and Client32

(Last modified: 11Dec2002)

This document (10012061) is provided subject to the disclaimer at the end of this document.

goal

Troubleshooting: MPREXE Errors in Windows 95 and Client32

fact

Microsoft Windows 95

Novell NetWare Client32

Formerly TID 2907849

MPREXE.EXE is a Microsoft file that allows Windows 95 to have more then one client and protocol.  MPR stands for Multi (or Multiple) Provider Router.  It's primary function is to route incoming and outgoing packet between the adapter and different clients.

symptom

Error: MPREXE caused a stack fault error in Kernel32.

Error: General Protection Fault in MPREXE.EXE.

Error: MPREXE caused invalid page fault.

Error: MPREXE This application performed an illegal operation and will be shut down.

Error: MPREXE caused an illegal page fault in module KERNEL32.DLL.

MPREXE is received when dialing out,  the station is docked, or when using the dialup PPP connection.

MPREXE is appearing at the beginning or during the login script processing.

cause

There are various causes that can create an MPREXE within Windows.  Below are the troubleshooting steps for MPREXE, and possible fixes.

fix

1.  Removing HIMEM.SYS from the CONFIG.SYS file will, in some cases, resolve this error.  To do this, restart the computer, press F8 when seeing "Starting Windows 95" on the top of the screen, then select the option "Command prompt only" in the menu.  You will then be on a dos prompt.  Use EDIT to modify the CONFIG.SYS and reboot the computer.  As a consequence, all device drivers and TSRs will be loaded in conventional memory.

    a. Although HIMEM.SYS has been removed from the CONFIG.SYS, it will still be loaded by Windows 95 (it is needed to access the extended memory), but somehow that prevents the GPF from occurring.

    b. After removing HIMEM.SYS, you will not be able to load EMM386.EXE anymore, which means that you will not be able to enable the upper memory area.  

2.  Delete and recreate all the network printers defined.  

To do this, remove HIMEM.SYS (see above) and restart the computer.  When in Windows 95, go into the printer folder and delete all the network printers.  Then, edit the CONFIG.SYS to put back HIMEM.SYS and restart the computer.  Then, recreate the network printers.  This solution is better than the first one since you will still be able to load device drivers and TSRs into upper memory, if needed.

symptom

  It has been determined that the MPREXE error has occurred when attempting to capture during the Login Script with certain conditions.

fix

  3a. In a NetWare 4.1 environment, login to the Directory Tree instead of a Server by editing the properties for Client 32, Login Tab and selecting "Log in to Tree".

  3b. Remove the capture statement from the Login Script and capture the print queue using Windows 95 network printer configuration.

cause

 Using the map change command in a login script could generate a MPREXE error. For example:  map c ins W: s3:

fix

 4. Currently the only solution is to not use the map change command in your login script.  This issue will be resolved with the next release of Client32

cause

The shipping version of the driver for the Matrox Millennium video cards (MGA)  will cause this error.

fix

5.Check the hardware specification of the computer if it ships with Matrox Millennium video cards (MGA) .  New drivers that solve the problem can be obtained from Matrox  at http://www.matrox.com/mgaweb/ftp.htm.The following computers were found with this video card built in: Gateway P166 machines Compaq Deskpro 6000

symptom

 Receiving MPREXE when using a dial-up adapter.

fix

6. In the case of using a dialup adapter and receiving a MPREXE error, removing Microsoft's IPX/SPX compatible protocol and Novell's IPX 32-bit protocol from the dialup adapter bindings resolved the error.  In some cases, TCP/IP was the only protocol required for the dialup adapter.  In other situations, however, other protocols will be required and further research will be needed to resolve the issue.

7.  Disable the GUI Login and run it from the startup folder.  

To disable the Client32 GUI login, create or modify the following registry entry:  
Set 'KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net\AutoLogon'  equal to 000 00.  If creating the AutoLogon Key, right click on RealMode Net, choose New and Binary.  The value 0000 00 means no login on bootup.  000 01 means Login on bootup.

cause

 The SET PATH statement in the AUTOEXEC.BAT if over 80 characters can cause a MPREXE.

fix

8. Ensure that the SET PATH statement in the AUTOEXEC.BAT is less than 80 characters.  The path statement can be broken into multiple lines which can be used to append together a statement that is longer then 80 characters.
Example
PATH C:\WINDOWS;C:\WINDOWS\COMMAND
PATH C:\NOVELL\CLIENT32;%PATH%

9. MAP a regular drive to a server in the tree that has the master replica.

cause

. Gateway P60 machines with bios revision 1.00.03.AF1 will not run with Client32 (Dos/Windows or Windows 95).

fix

10. Updating the bios to revision 1.00.06.AF1 (available form Gateway) will resolve this problem.

cause

When the DS has been altered, but the login script still references an invalid object, it can cause this error.

fix

11. Remove references in the login script to invalid DS objects.  

cause

Previous versions of the Novell client could possibly cause MPREXE.

fix

12. Install the latest Client for Windows 95.

cause

 Spanish version of Client32 for Windows 95 has improper regional configuration.

fix

 13. With the 32 bit Client for Windows 95 in Spanish and the Windows 95 in Spanish version too, you may have to configure the regional configuration in "Spanish from Spain (International Alphabet)".

symptom

 Date & Time on the Server is not current

cause

If the Server is set to year 2000 or later and every time Client32 connects to the server, the Client will set itself to the year the server is set to and Windows 95 does not handle the year 2000 easily and generate a General Protection Fault error.

fix

 14. Check with the latest Service Pack (3 or later) for Windows 95 to see if Microsoft has fixed the problem.

fact

 Microsoft has a limit of 39 characters on their group names, this is not a Novell limitation.  Novell's client will request from DS and successfully return the groups that a specific user is a member of.  The client will then hand these groups over to MPREXE.EXE for processing concerning the group policies.  Once a group name longer than 39 characters is passed to MPREXE.EXE, Microsoft's code will blow up.

cause

 If the group name in a group policy is greater than 39 characters, the client will MPREXE upon boot up.

Users who see this problem either have a group with a long name, or have a group in DS that is several containers down in the tree, thus giving the entire distinguished name of the group a character count greater than 39

fix

 15. To fix this either do not use group policies, limit the group policy name to 39 characters or less, or talk with Microsoft and ask them to modify their code to allow longer group names to be processed.

cause

Corrupt registry settings or incorrect Windows configuration.

fix

16. In some rare cases when nothing else has worked, reinstalling Windows 95 on the workstation has resolved the issue.  It is important to recreate the registry files during the reinstallation by completely deleting the existing Windows 95 configuration from the hard drive prior to reinstalling.

cause

Launching application from the login script with a #.  Using the # to launch apps in the login script pauses the login script until the app finishes and then returns to the login script.  If the app never returns to the login script, it causes an MPREXE.EXE error.

fix

17. Use the @ key to launch apps.  The @ key will run the application, but the login script will continue to finish without waiting for the completion of the app.

cause

Intel Pro 100 NIC card installs a Power Management tab that by default is turned on.

fix

Turn the Power Management tab to OFF.

Also, troubleshoot in MSCONFIG: the startup tab for ProMon can be turned on and off.

document

Document Title: Troubleshooting: MPREXE Errors in Windows 95 and Client32
Document ID: 10012061
Solution ID: 4.0.808143.2189644
Creation Date: 16Jun1999
Modified Date: 11Dec2002
Novell Product Class:NetWare

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