450 MX Lookup Failure, 450 Host Down and 550 Host Unknown Errors

(Last modified: 30Jan2004)

This document (10009322) is provided subject to the disclaimer at the end of this document.

fact

Novell GroupWise 5.5

Novell GroupWise 6.0

Novell GroupWise Internet Agent

symptom

Error: "450 Host down"

Error: "450 MX Lookup Failure"

Error: "550 Host unknown"

Errors show up in GWIA Log File or on the GWIA screen

Error sending outbound email

cause

A "450 MX Record Lookup Failure" message means that the SMTP or GWIA Gateway cannot find or connect with the Domain Name Server.

Possible reasons for 450 error:
1.  IP address to DNS has changed. If this is the case update the RESOLV.CFG
2.  IP filtering has been added to the routers so the gateway cannot see the DNS machine.
3.  Bad network card (NIC).
4.  TCP/IP is not bound to the network card.
5.  Bad network cabling.
6.  named is not running on the DNS machine.
7.  The DNS machine is down.
8.  The specific site your sending email may be down.  If you can send email to other locations, then in most cases all your GWIA/DNS settings are fine.  Try sending the email again later to see if their site is running.  A good test is loading ping at the server console and try pinging the site your trying to send email to.
9.  The ISP which is hosting the DNS may have the wrong entry for the MX record.

fix

Make sure you have a default route correctly configured.  See Configuring a Default Route.

Check the RESOLV.CFG file for correct configuration.  By default, this file is located in the SYS:\ETC directory.  Make sure it is spelled correctly.
The contents of the RESOLV.CFG file should be in all lowercase letters with the following format:
       domain <your_domain_name>
       nameserver <ip_address>
       nameserver <ip_address>
       nameserver <ip_address>

NOTE: In some cases changing the order of the nameservers, will resolve this issue.  That indicates a problem with the nameserver that was listed first in the list.

If you are using NAT on your server, add the following set command to the autoexec.ncf:
SET NAT DYNAMIC MODE TO PASS THRU=ON

If you are not hosting your own DNS, contact the ISP that is hosting your DNS can be sure that he has the correct MX record for your site.

cause

TCP/IP out of date.

fix

Make sure the server is fully patched.

cause

/mh switch is missing from gwia.cfg.

fix

Add the /mh-"Smart Mail Host IP Address" to the gwia.cfg file.
Some users do not want to resolve DNS for outgoing email.  In this case they must send all the outgoing internet email to a  Smart Mail Host.  This can also be done by adding the correct IP address to the Relay Host for Outbound Messages in the details of the GWIA object under SMTP/MIME Settings.

cause

/mh switch is incorrect from gwia.cfg

fix

If the /mh switch has been added to the gwia.cfg, or name of the Relay Host for Outbound Messages in the details of the GWIA object under SMTP/MIME Settings in NWADMN, however the host name is incorrect or that host is not running mail services.

cause

Filtering has been added to the routers so the gateway cannot see the DNS machine.

fix

Remove the filters that block the DNS machine.

document

Document Title: 450 MX Lookup Failure, 450 Host Down and 550 Host Unknown Errors
Document ID: 10009322
Solution ID: 1.0.889432.2061234
Creation Date: 18Mar1999
Modified Date: 30Jan2004
Novell Product Class:Connectivity Products
Groupware
NetWare
Novell BorderManager Services

disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.
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