Slow login to GroupWise WebAccess

(Last modified: 19Feb2003)

This document (10008300) is provided subject to the disclaimer at the end of this document.

fact

Novell GroupWise 5.2

Novell GroupWise 5.5

NetWare for Small Business

Novell Enterprise Server

NetWare 5

Novell NetWare 6.0

Novell GroupWise WebAccess 6.0

Novell GroupWise WebAccess

symptom

Slow login to GroupWise WebAccess

WebAccess is very slow when logging in.

Takes along time before folders and mail display in WebAccess

Slow performance occurs when using an unregistered IP address

cause

The problem occurs because the Webserver is doing a reverse lookup when displaying the folders and mail.

fix

To work-around the problem you can do one of the following:

1) Rename or delete the RESOLV.CFG file from the SYS:\ETC directory (on the Webserver. This will make webserver time out on its reverse lookup much faster and allow better performance. DO NOT rename the RESOLV.CFG on a server that is running GWIA or where DNS resolution is necessary.

2) Modify the webserver information to disable reverse lookups. To do so, perform the following steps.

a) Enter the Fastrack or Enterprise Web based Administration.
b) Select the server button.
c) Select Server Preferences | Performance Tuning | Enable DNS | No
d) Also disable the Async DNS on the same screen
e) Select Server Status | Log Preferences | Record IP Addresses
f) Save your changes and restart the Webserver.

3) If the WebAccess is on the same server as the post office try the following:

a) In NWAdmin go to the details of the WebAccess object.
b) Select the post office links tab.
c) Change the access mode to the post office to Direct Only.

4) If the WebAccess is on a different server than the post office follow #3 but change the link to Client Server Only.

NetWare 6
NOTE: If Apache is installed, try the following test (port 51080 is the default, use whatever port was assigned for Apache):

http://IP Address:51080/servlet/webacc

This should bring up a login screen for GroupWise WebAccess.  Try logging in and see if the speed improves.  If this is works, you can use Apache instead of NetWare Enterprise Web Server to get around this problem.

To fix the broken icon links do the following:

Copy the COM directory contained in the SYS:\NOVONYX\SUITESPOT\DOCS\ directory to the Apache document root (i.e. SYS:\APACHE\NWDOCS).

The INDEX.HTML page can be copied from SYS:\NOVONYX\SUITESPOT\DOCS\ to SYS:\APACHE\NWDOCS (rename existing one first).  This will give you the GO page for WebAccess or you can use the above address to bring up GroupWise WebAccess.

document

Document Title: Slow login to GroupWise WebAccess
Document ID: 10008300
Solution ID: 1.0.456086.2041060
Creation Date: 04Mar1999
Modified Date: 19Feb2003
Novell Product Class:Groupware
NetWare
Novonyx

disclaimer

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