Novell is now a part of Micro Focus

Security update for Acrobat Reader

Knowledgebase

(Last modified: 13JUL2005)


solutions Security update for Acrobat Reader SuSE Linux Maintenance Web (7c1a0c9c884f08dfefd2f3ca9e85e5d9)

Applies to

Package: acroread
glibc-locale-32bit
curl-32bit
Product(s): SUSE CORE 9 for AMD64 and Intel EM64T
Novell Linux Desktop 9 for x86_64
Patch: patch-10307
Release: 20050713
Obsoletes: none

Indications

Install this update if you are using Acrobat Reader.

Contraindications

None.

Problem description

This update fixes a buffer overflow in Acrobat Reader versions 5 and 7, where an attacker could execute code by providing a handmade PDF to the viewer.
The Acrobat Reader 5 versions of 9.1 and 9.2 were upgraded to Acrobat Reader 7. This version upgrade can cause new dependencies to appear, please check with the YaST Software Package Installation frontend if there are new dependencies and install the required packages.
Since this attack could be done via E-Mail messages or webpages, this should be considered to be remote exploitable.
This issue is tracked by the Mitre CVE ID CAN-2005-1625.

Solution

Please install the updates provided at the location noted below.

Installation notes

This update is provided as an RPM package that can easily be installed onto a running system by using this command:
rpm -Fvh acroread.rpm glibc-locale-32bit.rpm curl-32bit.rpm

links to download packages

Download Source Packages

Download the source code of the patches for maintained products.


Disclaimer

The Origin of this information may be internal or external to Novell. Novell makes all reasonable efforts to verify this information. However, the information provided in this document is for your information only. Novell makes no explicit or implied claims to the validity of this information.

Any trademarks referenced in this document are the property of their respective owners. Consult your product manuals for complete trademark information.

© Micro Focus