Novell Home

CVE-2014-2538

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-2538 at MITRE

Description

Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)

Novell/SUSE information

Novell Bugzilla entry: 869162

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.i586
Builds
SAT Patch Nr: 9098
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.ia64
Builds
SAT Patch Nr: 9098
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.ppc64
Builds
SAT Patch Nr: 9098
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.s390x
Builds
SAT Patch Nr: 9098
SUSE Linux Enterprise Software Development Kit 11 SP3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.x86_64
Builds
SAT Patch Nr: 9098
WebYaST 1.3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.i586
Builds
SAT Patch Nr: 9097
WebYaST 1.3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.ia64
Builds
SAT Patch Nr: 9097
WebYaST 1.3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.ppc64
Builds
SAT Patch Nr: 9097
WebYaST 1.3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.s390x
Builds
SAT Patch Nr: 9097
SUSE Lifecycle Management Server 1.3
SUSE Studio Onsite 1.3
WebYaST 1.3
  • rubygem-rack-ssl >= 1.3.2-0.12.5.1.x86_64
Builds
SAT Patch Nr: 9097

© 2014 Novell