Novell Home

CVE-2014-2338

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-2338 at MITRE

Description

IKEv2 in strongSwan 4.0.7 before 5.1.3 allows remote attackers to bypass authentication by rekeying an IKE_SA during (1) initiation or (2) re-authentication, which triggers the IKE_SA state to be set to established.

NVD CVSS v2 Base Score: 6.4 (AV:N/AC:L/Au:N/C:P/I:P/A:N)

Novell/SUSE information

Novell Bugzilla entry: 870572

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • strongswan-debuginfo >= 4.4.0-6.23.1
Builds
SAT Patch Nr: 9088
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • strongswan >= 4.4.0-6.23.1
  • strongswan-doc >= 4.4.0-6.23.1
Builds
SAT Patch Nr: 9089
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • strongswan >= 4.4.0-6.17.1
  • strongswan-doc >= 4.4.0-6.17.1
Builds
ZYPP Patch Nr: 8821
SUSE Linux Enterprise Server 11 SP2 LTSS
  • strongswan >= 4.4.0-6.23.1
  • strongswan-doc >= 4.4.0-6.23.1
Builds
SAT Patch Nr: 9091
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • strongswan >= 4.1.10-0.20.1
  • strongswan-doc >= 4.1.10-0.20.1
Builds
ZYPP Patch Nr: 8824
SUSE Linux Enterprise Server 11 SP1 LTSS
  • strongswan >= 4.4.0-6.23.1
  • strongswan-doc >= 4.4.0-6.23.1
Builds
SAT Patch Nr: 9090

© 2014 Novell