Novell Home

CVE-2014-1480

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2014-1480 at MITRE

Description

The file-download implementation in Mozilla Firefox before 27.0 and SeaMonkey before 2.24 does not properly restrict the timing of button selections, which allows remote attackers to conduct clickjacking attacks, and trigger unintended launching of a downloaded file, via a crafted web site.

NVD CVSS v2 Base Score: 4.3 (AV:N/AC:M/Au:N/C:N/I:P/A:N)

Novell/SUSE information

Novell Bugzilla entry: 861847

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • MozillaFirefox >= 24.5.0esr-0.7.2
  • MozillaFirefox-branding-SLED >= 24-0.12.1
  • MozillaFirefox-translations >= 24.5.0esr-0.7.2
  • firefox-atk >= 1.28.0-0.7.3
  • firefox-cairo >= 1.8.0-0.10.2
  • firefox-fontconfig >= 2.6.0-0.7.1
  • firefox-freetype2 >= 2.3.7-0.35.1
  • firefox-glib2 >= 2.22.5-0.13.3
  • firefox-gtk2 >= 2.18.9-0.9.2
  • firefox-gtk2-lang >= 2.18.9-0.9.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.22.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.22.1
  • firefox-pango >= 1.26.2-0.9.2
  • firefox-pcre >= 7.8-0.8.1
  • firefox-pixman >= 0.16.0-0.7.1
  • mozilla-nspr >= 4.10.4-0.5.1
  • mozilla-nspr-devel >= 4.10.4-0.5.1
  • mozilla-nss >= 3.16-0.5.1
  • mozilla-nss-devel >= 3.16-0.5.1
  • mozilla-nss-tools >= 3.16-0.5.1
  • mozilla-xulrunner191 >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-translations >= 1.9.1.19-0.13.3
  • mozilla-xulrunner192 >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-gnome >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-translations >= 1.9.2.28-0.13.4
Builds
ZYPP Patch Nr: 8851
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • MozillaFirefox >= 24.5.0esr-0.7.2
  • MozillaFirefox-branding-SLED >= 24-0.12.1
  • MozillaFirefox-translations >= 24.5.0esr-0.7.2
  • firefox-atk >= 1.28.0-0.7.3
  • firefox-atk-32bit >= 1.28.0-0.7.3
  • firefox-cairo >= 1.8.0-0.10.2
  • firefox-cairo-32bit >= 1.8.0-0.10.2
  • firefox-fontconfig >= 2.6.0-0.7.1
  • firefox-fontconfig-32bit >= 2.6.0-0.7.1
  • firefox-freetype2 >= 2.3.7-0.35.1
  • firefox-freetype2-32bit >= 2.3.7-0.35.1
  • firefox-glib2 >= 2.22.5-0.13.3
  • firefox-glib2-32bit >= 2.22.5-0.13.3
  • firefox-gtk2 >= 2.18.9-0.9.2
  • firefox-gtk2-32bit >= 2.18.9-0.9.2
  • firefox-gtk2-lang >= 2.18.9-0.9.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.22.1
  • firefox-libgcc_s1-32bit >= 4.7.2_20130108-0.22.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.22.1
  • firefox-libstdc++6-32bit >= 4.7.2_20130108-0.22.1
  • firefox-pango >= 1.26.2-0.9.2
  • firefox-pango-32bit >= 1.26.2-0.9.2
  • firefox-pcre >= 7.8-0.8.1
  • firefox-pcre-32bit >= 7.8-0.8.1
  • firefox-pixman >= 0.16.0-0.7.1
  • firefox-pixman-32bit >= 0.16.0-0.7.1
  • mozilla-nspr >= 4.10.4-0.5.1
  • mozilla-nspr-32bit >= 4.10.4-0.5.1
  • mozilla-nspr-devel >= 4.10.4-0.5.1
  • mozilla-nss >= 3.16-0.5.1
  • mozilla-nss-32bit >= 3.16-0.5.1
  • mozilla-nss-devel >= 3.16-0.5.1
  • mozilla-nss-tools >= 3.16-0.5.1
  • mozilla-xulrunner191 >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-32bit >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-translations >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.19-0.13.3
  • mozilla-xulrunner192 >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-32bit >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-gnome >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-translations >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-translations-32bit >= 1.9.2.28-0.13.4
Builds
ZYPP Patch Nr: 8851
SUSE Linux Enterprise Server 11 SP1 LTSS
  • MozillaFirefox >= 24.3.0esr-0.4.2.2
  • MozillaFirefox-branding-SLED >= 24-0.4.10.4
  • MozillaFirefox-translations >= 24.3.0esr-0.4.2.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.16.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.16.1
  • libfreebl3 >= 3.15.4-0.4.2.1
  • mozilla-nspr >= 4.10.2-0.3.2
  • mozilla-nss >= 3.15.4-0.4.2.1
  • mozilla-nss-tools >= 3.15.4-0.4.2.1
Builds
SAT Patch Nr: 8898
SUSE Linux Enterprise Server 11 SP1 LTSS
  • MozillaFirefox >= 24.3.0esr-0.4.2.2
  • MozillaFirefox-branding-SLED >= 24-0.4.10.4
  • MozillaFirefox-translations >= 24.3.0esr-0.4.2.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.16.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.16.1
  • libfreebl3 >= 3.15.4-0.4.2.1
  • libfreebl3-32bit >= 3.15.4-0.4.2.1
  • mozilla-nspr >= 4.10.2-0.3.2
  • mozilla-nspr-32bit >= 4.10.2-0.3.2
  • mozilla-nss >= 3.15.4-0.4.2.1
  • mozilla-nss-32bit >= 3.15.4-0.4.2.1
  • mozilla-nss-tools >= 3.15.4-0.4.2.1
Builds
SAT Patch Nr: 8898
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • MozillaFirefox >= 24.5.0esr-0.7.2
  • MozillaFirefox-branding-SLED >= 24-0.12.1
  • MozillaFirefox-translations >= 24.5.0esr-0.7.2
  • firefox-atk >= 1.28.0-0.7.3
  • firefox-cairo >= 1.8.0-0.10.2
  • firefox-fontconfig >= 2.6.0-0.7.1
  • firefox-freetype2 >= 2.3.7-0.35.1
  • firefox-glib2 >= 2.22.5-0.13.3
  • firefox-gtk2 >= 2.18.9-0.9.2
  • firefox-gtk2-lang >= 2.18.9-0.9.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.22.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.22.1
  • firefox-pango >= 1.26.2-0.9.2
  • firefox-pcre >= 7.8-0.8.1
  • firefox-pixman >= 0.16.0-0.7.1
  • mozilla-nspr >= 4.10.4-0.5.1
  • mozilla-nspr-devel >= 4.10.4-0.5.1
  • mozilla-nss >= 3.16-0.5.1
  • mozilla-nss-devel >= 3.16-0.5.1
  • mozilla-nss-tools >= 3.16-0.5.1
  • mozilla-xulrunner191 >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-translations >= 1.9.1.19-0.13.3
  • mozilla-xulrunner192 >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-gnome >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-translations >= 1.9.2.28-0.13.4
Builds
ZYPP Patch Nr: 8853
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • MozillaFirefox >= 24.5.0esr-0.7.2
  • MozillaFirefox-branding-SLED >= 24-0.12.1
  • MozillaFirefox-translations >= 24.5.0esr-0.7.2
  • firefox-atk >= 1.28.0-0.7.3
  • firefox-atk-32bit >= 1.28.0-0.7.3
  • firefox-cairo >= 1.8.0-0.10.2
  • firefox-cairo-32bit >= 1.8.0-0.10.2
  • firefox-fontconfig >= 2.6.0-0.7.1
  • firefox-fontconfig-32bit >= 2.6.0-0.7.1
  • firefox-freetype2 >= 2.3.7-0.35.1
  • firefox-freetype2-32bit >= 2.3.7-0.35.1
  • firefox-glib2 >= 2.22.5-0.13.3
  • firefox-glib2-32bit >= 2.22.5-0.13.3
  • firefox-gtk2 >= 2.18.9-0.9.2
  • firefox-gtk2-32bit >= 2.18.9-0.9.2
  • firefox-gtk2-lang >= 2.18.9-0.9.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.22.1
  • firefox-libgcc_s1-32bit >= 4.7.2_20130108-0.22.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.22.1
  • firefox-libstdc++6-32bit >= 4.7.2_20130108-0.22.1
  • firefox-pango >= 1.26.2-0.9.2
  • firefox-pango-32bit >= 1.26.2-0.9.2
  • firefox-pcre >= 7.8-0.8.1
  • firefox-pcre-32bit >= 7.8-0.8.1
  • firefox-pixman >= 0.16.0-0.7.1
  • firefox-pixman-32bit >= 0.16.0-0.7.1
  • mozilla-nspr >= 4.10.4-0.5.1
  • mozilla-nspr-32bit >= 4.10.4-0.5.1
  • mozilla-nspr-devel >= 4.10.4-0.5.1
  • mozilla-nss >= 3.16-0.5.1
  • mozilla-nss-32bit >= 3.16-0.5.1
  • mozilla-nss-devel >= 3.16-0.5.1
  • mozilla-nss-tools >= 3.16-0.5.1
  • mozilla-xulrunner191 >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-32bit >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-translations >= 1.9.1.19-0.13.3
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.19-0.13.3
  • mozilla-xulrunner192 >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-32bit >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-gnome >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-translations >= 1.9.2.28-0.13.4
  • mozilla-xulrunner192-translations-32bit >= 1.9.2.28-0.13.4
Builds
ZYPP Patch Nr: 8853
SUSE Linux Enterprise Server 11 SP2 LTSS
  • MozillaFirefox >= 24.3.0esr-0.4.2.2
  • MozillaFirefox-branding-SLED >= 24-0.4.10.4
  • MozillaFirefox-translations >= 24.3.0esr-0.4.2.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.16.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.16.1
  • libfreebl3 >= 3.15.4-0.4.2.1
  • mozilla-nspr >= 4.10.2-0.3.2
  • mozilla-nss >= 3.15.4-0.4.2.1
  • mozilla-nss-tools >= 3.15.4-0.4.2.1
Builds
SAT Patch Nr: 8899
SUSE Linux Enterprise Server 11 SP2 LTSS
  • MozillaFirefox >= 24.3.0esr-0.4.2.2
  • MozillaFirefox-branding-SLED >= 24-0.4.10.4
  • MozillaFirefox-translations >= 24.3.0esr-0.4.2.2
  • firefox-libgcc_s1 >= 4.7.2_20130108-0.16.1
  • firefox-libstdc++6 >= 4.7.2_20130108-0.16.1
  • libfreebl3 >= 3.15.4-0.4.2.1
  • libfreebl3-32bit >= 3.15.4-0.4.2.1
  • mozilla-nspr >= 4.10.2-0.3.2
  • mozilla-nspr-32bit >= 4.10.2-0.3.2
  • mozilla-nss >= 3.15.4-0.4.2.1
  • mozilla-nss-32bit >= 3.15.4-0.4.2.1
  • mozilla-nss-tools >= 3.15.4-0.4.2.1
Builds
SAT Patch Nr: 8899
SUSE Linux Enterprise Software Development Kit 11 SP3
  • MozillaFirefox-devel >= 24.3.0esr-0.8.1
  • mozilla-nss-devel >= 3.15.4-0.7.1
Builds
SAT Patch Nr: 8879
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 24.3.0esr-0.8.1
  • MozillaFirefox-branding-SLED >= 24-0.7.14
  • MozillaFirefox-translations >= 24.3.0esr-0.8.1
  • libfreebl3 >= 3.15.4-0.7.1
  • libsoftokn3 >= 3.15.4-0.7.1
  • mozilla-nss >= 3.15.4-0.7.1
  • mozilla-nss-tools >= 3.15.4-0.7.1
Builds
SAT Patch Nr: 8879
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 24.3.0esr-0.8.1
  • MozillaFirefox-branding-SLED >= 24-0.7.14
  • MozillaFirefox-translations >= 24.3.0esr-0.8.1
  • libfreebl3 >= 3.15.4-0.7.1
  • libfreebl3-32bit >= 3.15.4-0.7.1
  • libsoftokn3 >= 3.15.4-0.7.1
  • libsoftokn3-32bit >= 3.15.4-0.7.1
  • mozilla-nss >= 3.15.4-0.7.1
  • mozilla-nss-32bit >= 3.15.4-0.7.1
  • mozilla-nss-tools >= 3.15.4-0.7.1
Builds
SAT Patch Nr: 8879
SUSE Linux Enterprise Server 11 SP3 for VMware
  • MozillaFirefox >= 24.3.0esr-0.8.1
  • MozillaFirefox-translations >= 24.3.0esr-0.8.1
  • libfreebl3 >= 3.15.4-0.7.1
  • libsoftokn3 >= 3.15.4-0.7.1
  • mozilla-nss >= 3.15.4-0.7.1
  • mozilla-nss-tools >= 3.15.4-0.7.1
Builds
SAT Patch Nr: 8879
SUSE Linux Enterprise Server 11 SP3 for VMware
  • MozillaFirefox >= 24.3.0esr-0.8.1
  • MozillaFirefox-translations >= 24.3.0esr-0.8.1
  • libfreebl3 >= 3.15.4-0.7.1
  • libfreebl3-32bit >= 3.15.4-0.7.1
  • libsoftokn3 >= 3.15.4-0.7.1
  • libsoftokn3-32bit >= 3.15.4-0.7.1
  • mozilla-nss >= 3.15.4-0.7.1
  • mozilla-nss-32bit >= 3.15.4-0.7.1
  • mozilla-nss-tools >= 3.15.4-0.7.1
Builds
SAT Patch Nr: 8879
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 24.3.0esr-0.8.1
  • MozillaFirefox-branding-SLED >= 24-0.7.14
  • MozillaFirefox-translations >= 24.3.0esr-0.8.1
  • libfreebl3 >= 3.15.4-0.7.1
  • libfreebl3-x86 >= 3.15.4-0.7.1
  • libsoftokn3 >= 3.15.4-0.7.1
  • libsoftokn3-x86 >= 3.15.4-0.7.1
  • mozilla-nss >= 3.15.4-0.7.1
  • mozilla-nss-tools >= 3.15.4-0.7.1
  • mozilla-nss-x86 >= 3.15.4-0.7.1
Builds
SAT Patch Nr: 8879

© 2014 Novell