Novell Home

CVE-2013-7108

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-7108 at MITRE

Description

Multiple off-by-one errors in Nagios Core 3.5.1, 4.0.2, and earlier, and Icinga before 1.8.5, 1.9 before 1.9.4, and 1.10 before 1.10.2 allow remote authenticated users to obtain sensitive information from process memory or cause a denial of service (crash) via a long string in the last key value in the variable list to the process_cgivars function in (1) avail.c, (2) cmd.c, (3) config.c, (4) extinfo.c, (5) histogram.c, (6) notifications.c, (7) outages.c, (8) status.c, (9) statusmap.c, (10) summary.c, and (11) trends.c in cgi/, which triggers a heap-based buffer over-read.

NVD CVSS v2 Base Score: 5.5 (AV:N/AC:L/Au:S/C:P/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entry: 856837

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • nagios >= 3.0.6-1.25.34.1
  • nagios-devel >= 3.0.6-1.25.34.1
  • nagios-www >= 3.0.6-1.25.34.1
Builds
SAT Patch Nr: 8727
SUSE Linux Enterprise Software Development Kit 11 SP3
  • nagios-devel >= 3.0.6-1.25.34.1
Builds
SAT Patch Nr: 8727
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • nagios >= 3.0.6-1.25.34.1
  • nagios-www >= 3.0.6-1.25.34.1
Builds
SAT Patch Nr: 8727
SUSE Linux Enterprise Software Development Kit 11 SP2
  • nagios >= 3.0.6-1.25.34.1
  • nagios-devel >= 3.0.6-1.25.34.1
  • nagios-www >= 3.0.6-1.25.34.1
Builds
SAT Patch Nr: 8726
SUSE Linux Enterprise Software Development Kit 11 SP2
  • nagios-devel >= 3.0.6-1.25.34.1
Builds
SAT Patch Nr: 8726
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • nagios >= 3.0.6-1.25.34.1
  • nagios-www >= 3.0.6-1.25.34.1
Builds
SAT Patch Nr: 8726
SUSE CORE 9 for AMD64 and Intel EM64T
  • nagios >= 1.2-73.77
  • nagios-www >= 1.2-73.77
Builds
YOU Patch Nr: 12987

© 2014 Novell