Novell Home

CVE-2013-4132

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-4132 at MITRE

Description

KDE-Workspace 4.10.5 and earlier does not properly handle the return value of the glibc 2.17 crypt and pw_encrypt functions, which allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via (1) an invalid salt or a (2) DES or (3) MD5 encrypted password, when FIPS-140 is enable, to KDM or an (4) invalid password to KCheckPass.

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entry: 829857

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP3
  • kdebase4-workspace-devel >= 4.3.5-0.12.18.1
Builds
SAT Patch Nr: 9467
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • kde4-kgreeter-plugins >= 4.3.5-0.12.18.1
  • kdebase4-wallpapers >= 4.3.5-0.11.18.1
  • kdebase4-workspace >= 4.3.5-0.12.18.1
  • kdebase4-workspace-ksysguardd >= 4.3.5-0.12.18.1
  • kdm >= 4.3.5-0.12.18.1
  • kwin >= 4.3.5-0.12.18.1
Builds
SAT Patch Nr: 9467
SUSE Linux Enterprise Server 11 SP1
  • kdebase4-workspace-debuginfo >= 4.3.5-0.12.18.1
Builds
SAT Patch Nr: 9466

© 2014 Novell