Novell Home

CVE-2013-2126

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-2126 at MITRE

Description

Multiple double free vulnerabilities in the LibRaw::unpack function in libraw_cxx.cpp in LibRaw before 0.15.2 allow context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a malformed full-color (1) Foveon or (2) sRAW image file.

NVD CVSS v2 Base Score: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)

SUSE information

SUSE Bugzilla entries: 822665, 823113, 823114

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 12.3
  • darktable >= 1.1.3-1.5.3
  • darktable-debuginfo >= 1.1.3-1.5.3
  • darktable-debugsource >= 1.1.3-1.5.3
  • darktable-doc >= 1.1.3-1.5.3
  • libraw >= 0.14.7-3.4.1
  • libraw-debugsource >= 0.14.7-3.4.1
  • libraw-devel >= 0.14.7-3.4.1
  • libraw-devel-static >= 0.14.7-3.4.1
  • libraw-tools >= 0.14.7-3.4.1
  • libraw-tools-debuginfo >= 0.14.7-3.4.1
  • libraw5 >= 0.14.7-3.4.1
  • libraw5-debuginfo >= 0.14.7-3.4.1
Patchnames:
openSUSE-2013-537
openSUSE-2013-538

© 2015 Novell