Novell Home

CVE-2013-0746

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2013-0746 at MITRE

Description

Mozilla Firefox before 18.0, Firefox ESR 10.x before 10.0.12 and 17.x before 17.0.2, Thunderbird before 17.0.2, Thunderbird ESR 10.x before 10.0.12 and 17.x before 17.0.2, and SeaMonkey before 2.15 do not properly implement quickstubs that use the jsval data type for their return values, which allows remote attackers to execute arbitrary code or cause a denial of service (compartment mismatch and application crash) via crafted JavaScript code that is not properly handled during garbage collection.

NVD CVSS v2 Base Score: 9.3 (AV:N/AC:M/Au:N/C:C/I:C/A:C)

Novell/SUSE information

Novell Bugzilla entry: 796895

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • MozillaFirefox >= 10.0.12-0.6.3
  • MozillaFirefox-branding-SLED >= 7-0.8.46
  • MozillaFirefox-translations >= 10.0.12-0.6.3
  • firefox3-cairo >= 1.2.4-0.8.5
  • firefox3-gtk2 >= 2.10.6-0.12.21
  • firefox3-pango >= 1.14.5-0.12.178
  • mozilla-nspr >= 4.9.4-0.6.1
  • mozilla-nspr-devel >= 4.9.4-0.6.1
  • mozilla-nss >= 3.14.1-0.6.1
  • mozilla-nss-devel >= 3.14.1-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8454
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • MozillaFirefox >= 10.0.12-0.6.3
  • MozillaFirefox-branding-SLED >= 7-0.8.46
  • MozillaFirefox-translations >= 10.0.12-0.6.3
  • firefox3-cairo >= 1.2.4-0.8.5
  • firefox3-cairo-32bit >= 1.2.4-0.8.5
  • firefox3-gtk2 >= 2.10.6-0.12.21
  • firefox3-gtk2-32bit >= 2.10.6-0.12.21
  • firefox3-pango >= 1.14.5-0.12.178
  • firefox3-pango-32bit >= 1.14.5-0.12.178
  • mozilla-nspr >= 4.9.4-0.6.1
  • mozilla-nspr-32bit >= 4.9.4-0.6.1
  • mozilla-nspr-devel >= 4.9.4-0.6.1
  • mozilla-nss >= 3.14.1-0.6.1
  • mozilla-nss-32bit >= 3.14.1-0.6.1
  • mozilla-nss-devel >= 3.14.1-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8454
SUSE Linux Enterprise Software Development Kit 11 SP2
  • mozilla-nspr-devel >= 4.9.4-0.3.1
  • mozilla-nss-devel >= 3.14.1-0.3.1
Builds
SAT Patch Nr: 7224
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • MozillaFirefox >= 10.0.12-0.4.1
  • MozillaFirefox-translations >= 10.0.12-0.4.1
  • libfreebl3 >= 3.14.1-0.3.1
  • mozilla-nspr >= 4.9.4-0.3.1
  • mozilla-nss >= 3.14.1-0.3.1
  • mozilla-nss-tools >= 3.14.1-0.3.1
Builds
SAT Patch Nr: 7224
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • MozillaFirefox >= 10.0.12-0.4.1
  • MozillaFirefox-translations >= 10.0.12-0.4.1
  • libfreebl3 >= 3.14.1-0.3.1
  • libfreebl3-32bit >= 3.14.1-0.3.1
  • mozilla-nspr >= 4.9.4-0.3.1
  • mozilla-nspr-32bit >= 4.9.4-0.3.1
  • mozilla-nss >= 3.14.1-0.3.1
  • mozilla-nss-32bit >= 3.14.1-0.3.1
  • mozilla-nss-tools >= 3.14.1-0.3.1
Builds
SAT Patch Nr: 7224
SUSE Linux Enterprise Server 11 SP2
  • MozillaFirefox >= 10.0.12-0.4.1
  • MozillaFirefox-translations >= 10.0.12-0.4.1
  • libfreebl3 >= 3.14.1-0.3.1
  • libfreebl3-x86 >= 3.14.1-0.3.1
  • mozilla-nspr >= 4.9.4-0.3.1
  • mozilla-nspr-x86 >= 4.9.4-0.3.1
  • mozilla-nss >= 3.14.1-0.3.1
  • mozilla-nss-tools >= 3.14.1-0.3.1
  • mozilla-nss-x86 >= 3.14.1-0.3.1
Builds
SAT Patch Nr: 7224
SUSE Linux Enterprise Server 11 SP1 LTSS
  • MozillaFirefox >= 10.0.12-0.4.3
  • MozillaFirefox-branding-SLED >= 7-0.6.7.103
  • MozillaFirefox-translations >= 10.0.12-0.4.3
  • libfreebl3 >= 3.14.1-0.3.1
  • mozilla-nspr >= 4.9.4-0.3.1
  • mozilla-nss >= 3.14.1-0.3.1
  • mozilla-nss-tools >= 3.14.1-0.3.1
Builds
SAT Patch Nr: 7318
SUSE Linux Enterprise Server 11 SP1 LTSS
  • MozillaFirefox >= 10.0.12-0.4.3
  • MozillaFirefox-branding-SLED >= 7-0.6.7.103
  • MozillaFirefox-translations >= 10.0.12-0.4.3
  • libfreebl3 >= 3.14.1-0.3.1
  • libfreebl3-32bit >= 3.14.1-0.3.1
  • mozilla-nspr >= 4.9.4-0.3.1
  • mozilla-nspr-32bit >= 4.9.4-0.3.1
  • mozilla-nss >= 3.14.1-0.3.1
  • mozilla-nss-32bit >= 3.14.1-0.3.1
  • mozilla-nss-tools >= 3.14.1-0.3.1
Builds
SAT Patch Nr: 7318
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • MozillaFirefox >= 10.0.12-0.6.1
  • MozillaFirefox-translations >= 10.0.12-0.6.1
  • mozilla-nspr >= 4.9.4-0.6.1
  • mozilla-nspr-devel >= 4.9.4-0.6.1
  • mozilla-nss >= 3.14.1-0.6.1
  • mozilla-nss-devel >= 3.14.1-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8426
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • MozillaFirefox >= 10.0.12-0.6.1
  • MozillaFirefox-translations >= 10.0.12-0.6.1
  • mozilla-nspr >= 4.9.4-0.6.1
  • mozilla-nspr-32bit >= 4.9.4-0.6.1
  • mozilla-nspr-devel >= 4.9.4-0.6.1
  • mozilla-nss >= 3.14.1-0.6.1
  • mozilla-nss-32bit >= 3.14.1-0.6.1
  • mozilla-nss-devel >= 3.14.1-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8426
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • MozillaFirefox-branding-upstream >= 10.0.12-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8426
SUSE Linux Enterprise Server 10 SP4 for IPF
  • MozillaFirefox >= 10.0.12-0.6.1
  • MozillaFirefox-translations >= 10.0.12-0.6.1
  • mozilla-nspr >= 4.9.4-0.6.1
  • mozilla-nspr-devel >= 4.9.4-0.6.1
  • mozilla-nspr-x86 >= 4.9.4-0.6.1
  • mozilla-nss >= 3.14.1-0.6.1
  • mozilla-nss-devel >= 3.14.1-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
  • mozilla-nss-x86 >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8426
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • MozillaFirefox >= 10.0.12-0.6.1
  • MozillaFirefox-translations >= 10.0.12-0.6.1
  • mozilla-nspr >= 4.9.4-0.6.1
  • mozilla-nspr-64bit >= 4.9.4-0.6.1
  • mozilla-nspr-devel >= 4.9.4-0.6.1
  • mozilla-nss >= 3.14.1-0.6.1
  • mozilla-nss-64bit >= 3.14.1-0.6.1
  • mozilla-nss-devel >= 3.14.1-0.6.1
  • mozilla-nss-tools >= 3.14.1-0.6.1
Builds
ZYPP Patch Nr: 8426

© 2014 Novell