Novell Home

CVE-2012-4929

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-4929 at MITRE

Description

The TLS protocol 1.2 and earlier, as used in Mozilla Firefox, Google Chrome, Qt, and other products, can encrypt compressed data without properly obfuscating the length of the unencrypted data, which allows man-in-the-middle attackers to obtain plaintext HTTP headers by observing length differences during a series of guesses in which a string in an HTTP request potentially matches an unknown string in an HTTP header, aka a "CRIME" attack.

NVD CVSS v2 Base Score: 2.6 (AV:N/AC:H/Au:N/C:P/I:N/A:N)

Novell/SUSE information

Novell Bugzilla entries: 779952, 793420, 803004, 847895

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • openssl >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • openssl >= 0.9.8a-18.76.1
  • openssl-32bit >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-devel-32bit >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise 10 SP4 DEBUGINFO for AMD64 and Intel EM64T
SUSE Linux Enterprise 10 SP4 DEBUGINFO for IBM POWER
SUSE Linux Enterprise 10 SP4 DEBUGINFO for IBM zSeries 64bit
SUSE Linux Enterprise 10 SP4 DEBUGINFO for IPF
SUSE Linux Enterprise 10 SP4 DEBUGINFO for x86
  • openssl-debuginfo >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for x86
  • openssl >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for IPF
  • openssl >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
  • openssl-x86 >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • openssl >= 0.9.8a-18.76.1
  • openssl-64bit >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-devel-64bit >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.76.1
  • openssl-32bit >= 0.9.8a-18.76.1
  • openssl-devel >= 0.9.8a-18.76.1
  • openssl-devel-32bit >= 0.9.8a-18.76.1
  • openssl-doc >= 0.9.8a-18.76.1
Builds
ZYPP Patch Nr: 8517
SLE 11 SP2 DEBUGINFO
  • openssl-debuginfo >= 0.9.8j-0.50.1
  • openssl-debugsource >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libopenssl-devel >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-x86 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7548
SLE 11 SP2 DEBUGINFO
  • libqt4-debuginfo >= 4.6.3-5.18.1
  • libqt4-debugsource >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SLE 11 SP2 DEBUGINFO
  • libqt4-debuginfo >= 4.6.3-5.18.1
  • libqt4-debuginfo-x86 >= 4.6.3-5.18.1
  • libqt4-debugsource >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SLE 11 SP2 DEBUGINFO
  • libqt4-debuginfo >= 4.6.3-5.18.1
  • libqt4-debuginfo-32bit >= 4.6.3-5.18.1
  • libqt4-debugsource >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libQtWebKit-devel >= 4.6.3-5.18.1
  • libqt4-devel >= 4.6.3-5.18.1
  • libqt4-devel-doc-data >= 4.6.3-5.18.1
  • libqt4-sql-postgresql >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libQtWebKit-devel >= 4.6.3-5.18.1
  • libQtWebKit4-x86 >= 4.6.3-5.18.1
  • libqt4-devel >= 4.6.3-5.18.1
  • libqt4-devel-doc-data >= 4.6.3-5.18.1
  • libqt4-sql-mysql-x86 >= 4.6.3-5.18.1
  • libqt4-sql-postgresql >= 4.6.3-5.18.1
  • libqt4-sql-postgresql-x86 >= 4.6.3-5.18.1
  • libqt4-sql-sqlite-x86 >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC-x86 >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libQtWebKit-devel >= 4.6.3-5.18.1
  • libQtWebKit4-32bit >= 4.6.3-5.18.1
  • libqt4-devel >= 4.6.3-5.18.1
  • libqt4-devel-doc-data >= 4.6.3-5.18.1
  • libqt4-sql-mysql-32bit >= 4.6.3-5.18.1
  • libqt4-sql-postgresql >= 4.6.3-5.18.1
  • libqt4-sql-postgresql-32bit >= 4.6.3-5.18.1
  • libqt4-sql-sqlite-32bit >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC-32bit >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Desktop 11 SP2
  • libQtWebKit4 >= 4.6.3-5.18.1
  • libqt4 >= 4.6.3-5.18.1
  • libqt4-qt3support >= 4.6.3-5.18.1
  • libqt4-sql >= 4.6.3-5.18.1
  • libqt4-sql-mysql >= 4.6.3-5.18.1
  • libqt4-sql-postgresql >= 4.6.3-5.18.1
  • libqt4-sql-sqlite >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC >= 4.6.3-5.18.1
  • libqt4-x11 >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Desktop 11 SP2
  • libQtWebKit4 >= 4.6.3-5.18.1
  • libQtWebKit4-32bit >= 4.6.3-5.18.1
  • libqt4 >= 4.6.3-5.18.1
  • libqt4-32bit >= 4.6.3-5.18.1
  • libqt4-qt3support >= 4.6.3-5.18.1
  • libqt4-qt3support-32bit >= 4.6.3-5.18.1
  • libqt4-sql >= 4.6.3-5.18.1
  • libqt4-sql-32bit >= 4.6.3-5.18.1
  • libqt4-sql-mysql >= 4.6.3-5.18.1
  • libqt4-sql-mysql-32bit >= 4.6.3-5.18.1
  • libqt4-sql-postgresql >= 4.6.3-5.18.1
  • libqt4-sql-postgresql-32bit >= 4.6.3-5.18.1
  • libqt4-sql-sqlite >= 4.6.3-5.18.1
  • libqt4-sql-sqlite-32bit >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC >= 4.6.3-5.18.1
  • libqt4-sql-unixODBC-32bit >= 4.6.3-5.18.1
  • libqt4-x11 >= 4.6.3-5.18.1
  • libqt4-x11-32bit >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libQtWebKit4 >= 4.6.3-5.18.1
  • libqt4 >= 4.6.3-5.18.1
  • libqt4-qt3support >= 4.6.3-5.18.1
  • libqt4-sql >= 4.6.3-5.18.1
  • libqt4-sql-mysql >= 4.6.3-5.18.1
  • libqt4-sql-sqlite >= 4.6.3-5.18.1
  • libqt4-x11 >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Server 11 SP2
  • libQtWebKit4 >= 4.6.3-5.18.1
  • libQtWebKit4-x86 >= 4.6.3-5.18.1
  • libqt4 >= 4.6.3-5.18.1
  • libqt4-qt3support >= 4.6.3-5.18.1
  • libqt4-qt3support-x86 >= 4.6.3-5.18.1
  • libqt4-sql >= 4.6.3-5.18.1
  • libqt4-sql-mysql >= 4.6.3-5.18.1
  • libqt4-sql-sqlite >= 4.6.3-5.18.1
  • libqt4-sql-x86 >= 4.6.3-5.18.1
  • libqt4-x11 >= 4.6.3-5.18.1
  • libqt4-x11-x86 >= 4.6.3-5.18.1
  • libqt4-x86 >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • libQtWebKit4 >= 4.6.3-5.18.1
  • libQtWebKit4-32bit >= 4.6.3-5.18.1
  • libqt4 >= 4.6.3-5.18.1
  • libqt4-32bit >= 4.6.3-5.18.1
  • libqt4-qt3support >= 4.6.3-5.18.1
  • libqt4-qt3support-32bit >= 4.6.3-5.18.1
  • libqt4-sql >= 4.6.3-5.18.1
  • libqt4-sql-32bit >= 4.6.3-5.18.1
  • libqt4-sql-mysql >= 4.6.3-5.18.1
  • libqt4-sql-sqlite >= 4.6.3-5.18.1
  • libqt4-x11 >= 4.6.3-5.18.1
  • libqt4-x11-32bit >= 4.6.3-5.18.1
sles11-sp2-vmware.x86
sle11-sp2-sdk.x86
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.s390x
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.ppc
sles11-sp2.x86-64
sles11-sp2.ia64
sles11-sp2.s390x
sled11-sp2.x86
sles11-sp2.x86
sled11-sp2.x86-64
sles11-sp2.ppc
SAT Patch Nr: 6935
SUSE Linux Enterprise Server 10 SP3 DEBUGINFO
  • openssl-debuginfo >= 0.9.8a-18.45.69.1
Builds
ZYPP Patch Nr: 8528
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • openssl >= 0.9.8a-18.45.69.1
  • openssl-devel >= 0.9.8a-18.45.69.1
  • openssl-doc >= 0.9.8a-18.45.69.1
Builds
ZYPP Patch Nr: 8528
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.45.69.1
  • openssl-32bit >= 0.9.8a-18.45.69.1
  • openssl-devel >= 0.9.8a-18.45.69.1
  • openssl-devel-32bit >= 0.9.8a-18.45.69.1
  • openssl-doc >= 0.9.8a-18.45.69.1
Builds
ZYPP Patch Nr: 8528
SLE 11 SP1 DEBUGINFO
  • openssl-debuginfo >= 0.9.8j-0.50.1
  • openssl-debugsource >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7564
SUSE Linux Enterprise Server 11 SP1 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7564
SUSE Linux Enterprise Server 11 SP1 LTSS
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Builds
SAT Patch Nr: 7564

© 2014 Novell