Novell Home

CVE-2012-4557

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-4557 at MITRE

Description

The mod_proxy_ajp module in the Apache HTTP Server 2.2.12 through 2.2.21 places a worker node into an error state upon detection of a long request-processing time, which allows remote attackers to cause a denial of service (worker consumption) via an expensive request.

NVD CVSS v2 Base Score: 5.0 (AV:N/AC:L/Au:N/C:N/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entry: 788121

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • apache2 >= 2.2.3-16.32.45.1
  • apache2-devel >= 2.2.3-16.32.45.1
  • apache2-doc >= 2.2.3-16.32.45.1
  • apache2-example-pages >= 2.2.3-16.32.45.1
  • apache2-prefork >= 2.2.3-16.32.45.1
  • apache2-worker >= 2.2.3-16.32.45.1
Builds
ZYPP Patch Nr: 8453
SUSE Linux Enterprise Server 11 SP1 LTSS
  • apache2 >= 2.2.12-1.38.2
  • apache2-doc >= 2.2.12-1.38.2
  • apache2-example-pages >= 2.2.12-1.38.2
  • apache2-prefork >= 2.2.12-1.38.2
  • apache2-utils >= 2.2.12-1.38.2
  • apache2-worker >= 2.2.12-1.38.2
Builds
SAT Patch Nr: 7674
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • apache2 >= 2.2.3-16.46.1
  • apache2-devel >= 2.2.3-16.46.1
  • apache2-doc >= 2.2.3-16.46.1
  • apache2-example-pages >= 2.2.3-16.46.1
  • apache2-prefork >= 2.2.3-16.46.1
  • apache2-worker >= 2.2.3-16.46.1
Builds
ZYPP Patch Nr: 8443
SUSE Linux Enterprise Software Development Kit 11 SP2
  • apache2 >= 2.2.12-1.36.1
  • apache2-devel >= 2.2.12-1.36.1
  • apache2-doc >= 2.2.12-1.36.1
  • apache2-example-pages >= 2.2.12-1.36.1
  • apache2-prefork >= 2.2.12-1.36.1
  • apache2-utils >= 2.2.12-1.36.1
  • apache2-worker >= 2.2.12-1.36.1
Builds
SAT Patch Nr: 7409
SUSE Linux Enterprise Software Development Kit 11 SP2
  • apache2-devel >= 2.2.12-1.36.1
Builds
SAT Patch Nr: 7409
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • apache2 >= 2.2.12-1.36.1
  • apache2-doc >= 2.2.12-1.36.1
  • apache2-example-pages >= 2.2.12-1.36.1
  • apache2-prefork >= 2.2.12-1.36.1
  • apache2-utils >= 2.2.12-1.36.1
  • apache2-worker >= 2.2.12-1.36.1
Builds
SAT Patch Nr: 7409

© 2014 Novell