Novell Home

CVE-2012-3570

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-3570 at MITRE

Description

Buffer overflow in ISC DHCP 4.2.x before 4.2.4-P1, when DHCPv6 mode is enabled, allows remote attackers to cause a denial of service (segmentation fault and daemon exit) via a crafted client identifier parameter.

NVD CVSS v2 Base Score: 5.7 (AV:A/AC:M/Au:N/C:N/I:N/A:C)

Novell/SUSE information

Novell Bugzilla entry: 772924

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP2
  • dhcp-devel >= 4.2.4.P1-0.5.1
sles11-sp2.ppc
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86
sles11-sp2.x86
sles11-sp2.x86-64
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.s390x
sles11-sp2.s390x
sled11-sp2.x86-64
sles11-sp2-vmware.x86
sles11-sp2.ia64
sled11-sp2.x86
sle11-sp2-sdk.ppc
SAT Patch Nr: 6606
SUSE Linux Enterprise Desktop 11 SP2
  • dhcp >= 4.2.4.P1-0.5.1
  • dhcp-client >= 4.2.4.P1-0.5.1
sles11-sp2.ppc
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86
sles11-sp2.x86
sles11-sp2.x86-64
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.s390x
sles11-sp2.s390x
sled11-sp2.x86-64
sles11-sp2-vmware.x86
sles11-sp2.ia64
sled11-sp2.x86
sle11-sp2-sdk.ppc
SAT Patch Nr: 6606
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • dhcp >= 4.2.4.P1-0.5.1
  • dhcp-client >= 4.2.4.P1-0.5.1
  • dhcp-relay >= 4.2.4.P1-0.5.1
  • dhcp-server >= 4.2.4.P1-0.5.1
sles11-sp2.ppc
sle11-sp2-sdk.x86-64
sle11-sp2-sdk.ia64
sle11-sp2-sdk.x86
sles11-sp2.x86
sles11-sp2.x86-64
sles11-sp2-vmware.x86-64
sle11-sp2-sdk.s390x
sles11-sp2.s390x
sled11-sp2.x86-64
sles11-sp2-vmware.x86
sles11-sp2.ia64
sled11-sp2.x86
sle11-sp2-sdk.ppc
SAT Patch Nr: 6606

© 2014 Novell