Novell Home

CVE-2012-3174

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-3174 at MITRE

Description

Unspecified vulnerability in Oracle Java 7 before Update 11 allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors, a different vulnerability than CVE-2013-0422. NOTE: some parties have mapped CVE-2012-3174 to an issue involving recursive use of the Reflection API, but that issue is already covered as part of CVE-2013-0422. This identifier is for a different vulnerability whose details are not public as of 20130114.

NVD CVSS v2 Base Score: 10.0 (AV:N/AC:L/Au:N/C:C/I:C/A:C)

Novell/SUSE information

Note from the SUSE Security Team

This vulnerability affects implementions of Java 7, namely Oracle and IBM Java 7. A fixed OpenJDK 1.7.0 is being updated for openSUSE 12.2. IBM is also working on a fix for the java-1_7_0-ibm package on SUSE Linux Enterprise 11 and we will be releasing fixes as soon as they become available.,This vulnerability affects implementions of Java 7, namely Oracle and IBM Java 7. A fixed OpenJDK 1.7.0 is being updated for openSUSE 12.2. IBM is also working on a fix for the java-1_7_0-ibm package on SUSE Linux Enterprise 11 and we will be releasing fixes as soon as they become available.

Novell Bugzilla entries: 798324, 798521, 798535

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-alsa >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.7.7.1
Builds
ZYPP Patch Nr: 8497
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-32bit >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-devel-32bit >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.7.7.1
Builds
ZYPP Patch Nr: 8497
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-32bit >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-alsa-32bit >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-devel-32bit >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.7.7.1
  • java-1_6_0-ibm-plugin-32bit >= 1.6.0_sr13.0-0.7.7.1
Builds
ZYPP Patch Nr: 8497
SUSE CORE 9 for AMD64 and Intel EM64T
SUSE CORE 9 for IBM S/390 31bit
SUSE CORE 9 for IBM zSeries 64bit
SUSE CORE 9 for x86
  • IBMJava5-JRE >= 1.5.0_sr16.0-0.4
  • IBMJava5-SDK >= 1.5.0_sr16.0-0.4
Builds
YOU Patch Nr: 12936
SUSE CORE 9 for AMD64 and Intel EM64T
SUSE CORE 9 for IBM S/390 31bit
SUSE CORE 9 for IBM zSeries 64bit
SUSE CORE 9 for x86
  • IBMJava2-JRE >= 1.4.2_sr13.15-0.4
  • IBMJava2-SDK >= 1.4.2_sr13.15-0.4
Builds
YOU Patch Nr: 12935
SUSE CORE 9 for AMD64 and Intel EM64T
  • IBMJava2-JRE >= 1.4.2_sr13.15-0.2
  • IBMJava2-SDK >= 1.4.2_sr13.15-0.2
Builds
YOU Patch Nr: 12931
SUSE Linux Enterprise Server 11 SP1 LTSS
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-alsa >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7482
SUSE Linux Enterprise Server 11 SP1 LTSS
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7482
SUSE Linux Enterprise Server 11 SP1 LTSS
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7482
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-alsa >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8494
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8494
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-alsa-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8494
SUSE Linux Enterprise Server 11 SP1 LTSS
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.3.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.15-0.3.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.15-0.3.1
Builds
SAT Patch Nr: 7479
SUSE Linux Enterprise Server 11 SP1 LTSS
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.3.1
Builds
SAT Patch Nr: 7479
SUSE Linux Enterprise Server 10 SP4 for x86
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-alsa >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.13.3
Builds
ZYPP Patch Nr: 8495
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-64bit >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.13.3
Builds
ZYPP Patch Nr: 8495
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-32bit >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-devel-32bit >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.13.3
Builds
ZYPP Patch Nr: 8495
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-32bit >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-alsa-32bit >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-devel-32bit >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.13.3
  • java-1_6_0-ibm-plugin-32bit >= 1.6.0_sr13.0-0.13.3
Builds
ZYPP Patch Nr: 8495
SUSE Linux Enterprise Server 10 SP4 for x86
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.15-0.6.1
Builds
ZYPP Patch Nr: 8481
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.6.1
Builds
ZYPP Patch Nr: 8481
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.15-0.6.1
Builds
ZYPP Patch Nr: 8481
SUSE Linux Enterprise Software Development Kit 11 SP2
  • java-1_7_0-ibm-devel >= 1.7.0_sr4.0-0.6.1
Builds
SAT Patch Nr: 7454
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • java-1_7_0-ibm >= 1.7.0_sr4.0-0.6.1
  • java-1_7_0-ibm-alsa >= 1.7.0_sr4.0-0.6.1
  • java-1_7_0-ibm-jdbc >= 1.7.0_sr4.0-0.6.1
  • java-1_7_0-ibm-plugin >= 1.7.0_sr4.0-0.6.1
Builds
SAT Patch Nr: 7454
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • java-1_7_0-ibm >= 1.7.0_sr4.0-0.6.1
  • java-1_7_0-ibm-jdbc >= 1.7.0_sr4.0-0.6.1
  • java-1_7_0-ibm-plugin >= 1.7.0_sr4.0-0.6.1
Builds
SAT Patch Nr: 7454
SUSE Linux Enterprise Server 11 SP2
  • java-1_7_0-ibm >= 1.7.0_sr4.0-0.6.1
  • java-1_7_0-ibm-jdbc >= 1.7.0_sr4.0-0.6.1
Builds
SAT Patch Nr: 7454
SUSE Linux Enterprise Software Development Kit 11 SP2
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.3.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.3.1
Builds
SAT Patch Nr: 7450
SUSE Linux Enterprise Software Development Kit 11 SP2
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.3.1
Builds
SAT Patch Nr: 7450
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.3.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.15-0.3.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.15-0.3.1
Builds
SAT Patch Nr: 7450
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.3.1
Builds
SAT Patch Nr: 7450
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-alsa >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-demo >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-src >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8483
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-alsa-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-demo >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-src >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8483
SUSE Linux Enterprise Server 10 SP4 for x86
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-alsa >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8483
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-64bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-jdbc >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-plugin >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8483
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8483
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
  • java-1_5_0-ibm >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-alsa-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-devel-32bit >= 1.5.0_sr16.0-0.6.1
  • java-1_5_0-ibm-fonts >= 1.5.0_sr16.0-0.6.1
Builds
ZYPP Patch Nr: 8483
SUSE CORE 9 for AMD64 and Intel EM64T
  • IBMJava5-JRE >= 1.5.0_sr16.0-0.2
  • IBMJava5-SDK >= 1.5.0_sr16.0-0.2
Builds
YOU Patch Nr: 12932
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-jdbc >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-plugin >= 1.4.2_sr13.15-0.6.1
Builds
ZYPP Patch Nr: 8493
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • java-1_4_2-ibm >= 1.4.2_sr13.15-0.6.1
  • java-1_4_2-ibm-devel >= 1.4.2_sr13.15-0.6.1
Builds
ZYPP Patch Nr: 8493
SUSE Linux Enterprise Software Development Kit 11 SP2
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7481
SUSE Linux Enterprise Software Development Kit 11 SP2
  • java-1_6_0-ibm-devel >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7481
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-alsa >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7481
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-plugin >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7481
SUSE Linux Enterprise Server 11 SP2
  • java-1_6_0-ibm >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-fonts >= 1.6.0_sr13.0-0.8.1
  • java-1_6_0-ibm-jdbc >= 1.6.0_sr13.0-0.8.1
Builds
SAT Patch Nr: 7481

© 2014 Novell