Novell Home

CVE-2012-2814

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2814 at MITRE

Description

Buffer overflow in the exif_entry_format_value function in exif-entry.c in the EXIF Tag Parsing Library (aka libexif) 0.6.20 allows remote attackers to cause a denial of service or possibly execute arbitrary code via crafted EXIF tags in an image.

NVD CVSS v2 Base Score: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entry: 771229, 831515

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SLE 11 SP1 DEBUGINFO
  • libexif-debuginfo >= 0.6.17-2.14.1
  • libexif-debugsource >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SLE 11 SP1 DEBUGINFO
  • libexif-debuginfo >= 0.6.17-2.14.1
  • libexif-debuginfo-x86 >= 0.6.17-2.14.1
  • libexif-debugsource >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SLE 11 SP1 DEBUGINFO
  • libexif-debuginfo >= 0.6.17-2.14.1
  • libexif-debuginfo-32bit >= 0.6.17-2.14.1
  • libexif-debugsource >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libexif-devel >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libexif >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libexif >= 0.6.17-2.14.1
  • libexif-x86 >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libexif >= 0.6.17-2.14.1
  • libexif-32bit >= 0.6.17-2.14.1
Builds
SAT Patch Nr: 6568
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • libexif >= 0.6.13-20.14.1
Builds
ZYPP Patch Nr: 8224
SUSE Linux Enterprise Server 10 SP4 for IPF
  • libexif >= 0.6.13-20.14.1
  • libexif-x86 >= 0.6.13-20.14.1
Builds
ZYPP Patch Nr: 8224
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • libexif >= 0.6.13-20.14.1
  • libexif-64bit >= 0.6.13-20.14.1
Builds
ZYPP Patch Nr: 8224
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • libexif >= 0.6.13-20.14.1
  • libexif-32bit >= 0.6.13-20.14.1
Builds
ZYPP Patch Nr: 8224

© 2014 Novell