Novell Home

CVE-2012-2806

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2806 at MITRE

Description

Heap-based buffer overflow in the get_sos function in jdmarker.c in libjpeg-turbo 1.2.0 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a large component count in the header of a JPEG image.

NVD CVSS v2 Base Score: 6.8 (AV:N/AC:M/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entry: 771791

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CORE 9 for AMD64 and Intel EM64T
  • jpeg >= 6b-731.4
  • libjpeg >= 6.2.0-731.4
  • libjpeg-32bit >= 9-201207240906
Builds
YOU Patch Nr: 12902
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libjpeg-devel >= 6.2.0-879.12.1
sle11-sp2-sdk.ia64
sle11-sp2-sdk.s390x
sle11-sp1-sdk.s390x
sles11-sp2.s390x
sle11-sp1-sdk.x86
sled11-sp1.x86-64
sled11-sp2.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sled11-sp2.x86-64
sled11-sp1.x86
sle11-sp2-sdk.ppc
sle11-sp2-sdk.x86-64
sles11-sp2.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sles11-sp2.ia64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sles11-sp2.ppc
sle11-sp1-sdk.x86-64
sle11-sp2-sdk.x86
SAT Patch Nr: 6586
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libjpeg-devel >= 6.2.0-879.12.1
  • libjpeg-devel-32bit >= 6.2.0-879.12.1
sle11-sp2-sdk.ia64
sle11-sp2-sdk.s390x
sle11-sp1-sdk.s390x
sles11-sp2.s390x
sle11-sp1-sdk.x86
sled11-sp1.x86-64
sled11-sp2.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sled11-sp2.x86-64
sled11-sp1.x86
sle11-sp2-sdk.ppc
sle11-sp2-sdk.x86-64
sles11-sp2.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sles11-sp2.ia64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sles11-sp2.ppc
sle11-sp1-sdk.x86-64
sle11-sp2-sdk.x86
SAT Patch Nr: 6586
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • jpeg >= 6b-879.12.1
  • libjpeg >= 6.2.0-879.12.1
sle11-sp2-sdk.ia64
sle11-sp2-sdk.s390x
sle11-sp1-sdk.s390x
sles11-sp2.s390x
sle11-sp1-sdk.x86
sled11-sp1.x86-64
sled11-sp2.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sled11-sp2.x86-64
sled11-sp1.x86
sle11-sp2-sdk.ppc
sle11-sp2-sdk.x86-64
sles11-sp2.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sles11-sp2.ia64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sles11-sp2.ppc
sle11-sp1-sdk.x86-64
sle11-sp2-sdk.x86
SAT Patch Nr: 6586
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • jpeg >= 6b-879.12.1
  • libjpeg >= 6.2.0-879.12.1
  • libjpeg-32bit >= 6.2.0-879.12.1
sle11-sp2-sdk.ia64
sle11-sp2-sdk.s390x
sle11-sp1-sdk.s390x
sles11-sp2.s390x
sle11-sp1-sdk.x86
sled11-sp1.x86-64
sled11-sp2.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sled11-sp2.x86-64
sled11-sp1.x86
sle11-sp2-sdk.ppc
sle11-sp2-sdk.x86-64
sles11-sp2.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sles11-sp2.ia64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sles11-sp2.ppc
sle11-sp1-sdk.x86-64
sle11-sp2-sdk.x86
SAT Patch Nr: 6586
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • jpeg >= 6b-879.12.1
  • libjpeg >= 6.2.0-879.12.1
  • libjpeg-x86 >= 6.2.0-879.12.1
sle11-sp2-sdk.ia64
sle11-sp2-sdk.s390x
sle11-sp1-sdk.s390x
sles11-sp2.s390x
sle11-sp1-sdk.x86
sled11-sp1.x86-64
sled11-sp2.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sled11-sp2.x86-64
sled11-sp1.x86
sle11-sp2-sdk.ppc
sle11-sp2-sdk.x86-64
sles11-sp2.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sles11-sp2.ia64
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sles11-sp2.ppc
sle11-sp1-sdk.x86-64
sle11-sp2-sdk.x86
SAT Patch Nr: 6586
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • jpeg >= 6b-752.8.45
  • libjpeg >= 6.2.0-752.8.45
  • libjpeg-devel >= 6.2.0-18.8.45
sles10-sp4.x86-64
sles10-sp4.ia64
sled10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4.x86
sles10-sp4.ppc
sled10-sp4.x86
ZYPP Patch Nr: 8233
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • jpeg >= 6b-752.8.45
  • libjpeg >= 6.2.0-752.8.45
  • libjpeg-32bit >= 6.2.0-752.8.45
  • libjpeg-devel >= 6.2.0-18.8.45
  • libjpeg-devel-32bit >= 6.2.0-18.8.45
sles10-sp4.x86-64
sles10-sp4.ia64
sled10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4.x86
sles10-sp4.ppc
sled10-sp4.x86
ZYPP Patch Nr: 8233
SUSE Linux Enterprise Server 10 SP4 for IPF
  • jpeg >= 6b-752.8.45
  • libjpeg >= 6.2.0-752.8.45
  • libjpeg-devel >= 6.2.0-18.8.45
  • libjpeg-x86 >= 6.2.0-752.8.45
sles10-sp4.x86-64
sles10-sp4.ia64
sled10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4.x86
sles10-sp4.ppc
sled10-sp4.x86
ZYPP Patch Nr: 8233
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • jpeg >= 6b-752.8.45
  • libjpeg >= 6.2.0-752.8.45
  • libjpeg-64bit >= 6.2.0-752.8.45
  • libjpeg-devel >= 6.2.0-18.8.45
  • libjpeg-devel-64bit >= 6.2.0-18.8.45
sles10-sp4.x86-64
sles10-sp4.ia64
sled10-sp4.x86-64
sles10-sp4.s390x
sles10-sp4.x86
sles10-sp4.ppc
sled10-sp4.x86
ZYPP Patch Nr: 8233

© 2014 Novell