Novell Home

CVE-2012-2688

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2688 at MITRE

Description

Unspecified vulnerability in the _php_stream_scandir function in the stream implementation in PHP before 5.3.15 and 5.4.x before 5.4.5 has unknown impact and remote attack vectors, related to an "overflow."

NVD CVSS v2 Base Score: 10.0 (AV:N/AC:L/Au:N/C:C/I:C/A:C)

Novell/SUSE information

Novell Bugzilla entry: 772582

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • apache2-mod_php5 >= 5.2.14-0.42.1
  • php5 >= 5.2.14-0.42.1
  • php5-bcmath >= 5.2.14-0.42.1
  • php5-bz2 >= 5.2.14-0.42.1
  • php5-calendar >= 5.2.14-0.42.1
  • php5-ctype >= 5.2.14-0.42.1
  • php5-curl >= 5.2.14-0.42.1
  • php5-dba >= 5.2.14-0.42.1
  • php5-dbase >= 5.2.14-0.42.1
  • php5-devel >= 5.2.14-0.42.1
  • php5-dom >= 5.2.14-0.42.1
  • php5-exif >= 5.2.14-0.42.1
  • php5-fastcgi >= 5.2.14-0.42.1
  • php5-ftp >= 5.2.14-0.42.1
  • php5-gd >= 5.2.14-0.42.1
  • php5-gettext >= 5.2.14-0.42.1
  • php5-gmp >= 5.2.14-0.42.1
  • php5-hash >= 5.2.14-0.42.1
  • php5-iconv >= 5.2.14-0.42.1
  • php5-imap >= 5.2.14-0.42.1
  • php5-json >= 5.2.14-0.42.1
  • php5-ldap >= 5.2.14-0.42.1
  • php5-mbstring >= 5.2.14-0.42.1
  • php5-mcrypt >= 5.2.14-0.42.1
  • php5-mhash >= 5.2.14-0.42.1
  • php5-mysql >= 5.2.14-0.42.1
  • php5-ncurses >= 5.2.14-0.42.1
  • php5-odbc >= 5.2.14-0.42.1
  • php5-openssl >= 5.2.14-0.42.1
  • php5-pcntl >= 5.2.14-0.42.1
  • php5-pdo >= 5.2.14-0.42.1
  • php5-pear >= 5.2.14-0.42.1
  • php5-pgsql >= 5.2.14-0.42.1
  • php5-posix >= 5.2.14-0.42.1
  • php5-pspell >= 5.2.14-0.42.1
  • php5-shmop >= 5.2.14-0.42.1
  • php5-snmp >= 5.2.14-0.42.1
  • php5-soap >= 5.2.14-0.42.1
  • php5-sockets >= 5.2.14-0.42.1
  • php5-sqlite >= 5.2.14-0.42.1
  • php5-suhosin >= 5.2.14-0.42.1
  • php5-sysvmsg >= 5.2.14-0.42.1
  • php5-sysvsem >= 5.2.14-0.42.1
  • php5-sysvshm >= 5.2.14-0.42.1
  • php5-tokenizer >= 5.2.14-0.42.1
  • php5-wddx >= 5.2.14-0.42.1
  • php5-xmlreader >= 5.2.14-0.42.1
  • php5-xmlrpc >= 5.2.14-0.42.1
  • php5-xsl >= 5.2.14-0.42.1
  • php5-zlib >= 5.2.14-0.42.1
Builds
ZYPP Patch Nr: 8658
SUSE Linux Enterprise Software Development Kit 11 SP2
  • php53-devel >= 5.3.8-0.35.1
  • php53-imap >= 5.3.8-0.35.1
  • php53-posix >= 5.3.8-0.35.1
  • php53-readline >= 5.3.8-0.35.1
  • php53-sockets >= 5.3.8-0.35.1
  • php53-sqlite >= 5.3.8-0.35.1
  • php53-tidy >= 5.3.8-0.35.1
sles11-sp2.ia64
sles11-sp2.ppc
sles11-sp2.x86-64
sles11-sp2.s390x
sles11-sp2.x86
SAT Patch Nr: 6634
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
  • apache2-mod_php53 >= 5.3.8-0.35.1
  • php53 >= 5.3.8-0.35.1
  • php53-bcmath >= 5.3.8-0.35.1
  • php53-bz2 >= 5.3.8-0.35.1
  • php53-calendar >= 5.3.8-0.35.1
  • php53-ctype >= 5.3.8-0.35.1
  • php53-curl >= 5.3.8-0.35.1
  • php53-dba >= 5.3.8-0.35.1
  • php53-dom >= 5.3.8-0.35.1
  • php53-exif >= 5.3.8-0.35.1
  • php53-fastcgi >= 5.3.8-0.35.1
  • php53-fileinfo >= 5.3.8-0.35.1
  • php53-ftp >= 5.3.8-0.35.1
  • php53-gd >= 5.3.8-0.35.1
  • php53-gettext >= 5.3.8-0.35.1
  • php53-gmp >= 5.3.8-0.35.1
  • php53-iconv >= 5.3.8-0.35.1
  • php53-intl >= 5.3.8-0.35.1
  • php53-json >= 5.3.8-0.35.1
  • php53-ldap >= 5.3.8-0.35.1
  • php53-mbstring >= 5.3.8-0.35.1
  • php53-mcrypt >= 5.3.8-0.35.1
  • php53-mysql >= 5.3.8-0.35.1
  • php53-odbc >= 5.3.8-0.35.1
  • php53-openssl >= 5.3.8-0.35.1
  • php53-pcntl >= 5.3.8-0.35.1
  • php53-pdo >= 5.3.8-0.35.1
  • php53-pear >= 5.3.8-0.35.1
  • php53-pgsql >= 5.3.8-0.35.1
  • php53-pspell >= 5.3.8-0.35.1
  • php53-shmop >= 5.3.8-0.35.1
  • php53-snmp >= 5.3.8-0.35.1
  • php53-soap >= 5.3.8-0.35.1
  • php53-suhosin >= 5.3.8-0.35.1
  • php53-sysvmsg >= 5.3.8-0.35.1
  • php53-sysvsem >= 5.3.8-0.35.1
  • php53-sysvshm >= 5.3.8-0.35.1
  • php53-tokenizer >= 5.3.8-0.35.1
  • php53-wddx >= 5.3.8-0.35.1
  • php53-xmlreader >= 5.3.8-0.35.1
  • php53-xmlrpc >= 5.3.8-0.35.1
  • php53-xmlwriter >= 5.3.8-0.35.1
  • php53-xsl >= 5.3.8-0.35.1
  • php53-zip >= 5.3.8-0.35.1
  • php53-zlib >= 5.3.8-0.35.1
sles11-sp2.ia64
sles11-sp2.ppc
sles11-sp2.x86-64
sles11-sp2.s390x
sles11-sp2.x86
SAT Patch Nr: 6634
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • apache2-mod_php5 >= 5.2.14-0.36.1
  • php5 >= 5.2.14-0.36.1
  • php5-bcmath >= 5.2.14-0.36.1
  • php5-bz2 >= 5.2.14-0.36.1
  • php5-calendar >= 5.2.14-0.36.1
  • php5-ctype >= 5.2.14-0.36.1
  • php5-curl >= 5.2.14-0.36.1
  • php5-dba >= 5.2.14-0.36.1
  • php5-dbase >= 5.2.14-0.36.1
  • php5-devel >= 5.2.14-0.36.1
  • php5-dom >= 5.2.14-0.36.1
  • php5-exif >= 5.2.14-0.36.1
  • php5-fastcgi >= 5.2.14-0.36.1
  • php5-ftp >= 5.2.14-0.36.1
  • php5-gd >= 5.2.14-0.36.1
  • php5-gettext >= 5.2.14-0.36.1
  • php5-gmp >= 5.2.14-0.36.1
  • php5-hash >= 5.2.14-0.36.1
  • php5-iconv >= 5.2.14-0.36.1
  • php5-imap >= 5.2.14-0.36.1
  • php5-ldap >= 5.2.14-0.36.1
  • php5-mbstring >= 5.2.14-0.36.1
  • php5-mcrypt >= 5.2.14-0.36.1
  • php5-mhash >= 5.2.14-0.36.1
  • php5-mysql >= 5.2.14-0.36.1
  • php5-ncurses >= 5.2.14-0.36.1
  • php5-odbc >= 5.2.14-0.36.1
  • php5-openssl >= 5.2.14-0.36.1
  • php5-pcntl >= 5.2.14-0.36.1
  • php5-pdo >= 5.2.14-0.36.1
  • php5-pear >= 5.2.14-0.36.1
  • php5-pgsql >= 5.2.14-0.36.1
  • php5-posix >= 5.2.14-0.36.1
  • php5-pspell >= 5.2.14-0.36.1
  • php5-shmop >= 5.2.14-0.36.1
  • php5-snmp >= 5.2.14-0.36.1
  • php5-soap >= 5.2.14-0.36.1
  • php5-sockets >= 5.2.14-0.36.1
  • php5-sqlite >= 5.2.14-0.36.1
  • php5-suhosin >= 5.2.14-0.36.1
  • php5-sysvmsg >= 5.2.14-0.36.1
  • php5-sysvsem >= 5.2.14-0.36.1
  • php5-sysvshm >= 5.2.14-0.36.1
  • php5-tidy >= 5.2.14-0.36.1
  • php5-tokenizer >= 5.2.14-0.36.1
  • php5-wddx >= 5.2.14-0.36.1
  • php5-xmlreader >= 5.2.14-0.36.1
  • php5-xmlrpc >= 5.2.14-0.36.1
  • php5-xsl >= 5.2.14-0.36.1
  • php5-zlib >= 5.2.14-0.36.1
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.x86
sles10-sp4.ia64
sles10-sp4.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sles10-sp4.x86-64
sle10-sp4-sdk.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4-debuginfo.x86-64
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.ia64
sle10-sp4-sdk.x86-64
ZYPP Patch Nr: 8239
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 for IPF
SUSE Linux Enterprise Server 10 SP4 for x86
  • apache2-mod_php5 >= 5.2.14-0.36.1
  • php5 >= 5.2.14-0.36.1
  • php5-bcmath >= 5.2.14-0.36.1
  • php5-bz2 >= 5.2.14-0.36.1
  • php5-calendar >= 5.2.14-0.36.1
  • php5-ctype >= 5.2.14-0.36.1
  • php5-curl >= 5.2.14-0.36.1
  • php5-dba >= 5.2.14-0.36.1
  • php5-dbase >= 5.2.14-0.36.1
  • php5-devel >= 5.2.14-0.36.1
  • php5-dom >= 5.2.14-0.36.1
  • php5-exif >= 5.2.14-0.36.1
  • php5-fastcgi >= 5.2.14-0.36.1
  • php5-ftp >= 5.2.14-0.36.1
  • php5-gd >= 5.2.14-0.36.1
  • php5-gettext >= 5.2.14-0.36.1
  • php5-gmp >= 5.2.14-0.36.1
  • php5-hash >= 5.2.14-0.36.1
  • php5-iconv >= 5.2.14-0.36.1
  • php5-imap >= 5.2.14-0.36.1
  • php5-json >= 5.2.14-0.36.1
  • php5-ldap >= 5.2.14-0.36.1
  • php5-mbstring >= 5.2.14-0.36.1
  • php5-mcrypt >= 5.2.14-0.36.1
  • php5-mhash >= 5.2.14-0.36.1
  • php5-mysql >= 5.2.14-0.36.1
  • php5-ncurses >= 5.2.14-0.36.1
  • php5-odbc >= 5.2.14-0.36.1
  • php5-openssl >= 5.2.14-0.36.1
  • php5-pcntl >= 5.2.14-0.36.1
  • php5-pdo >= 5.2.14-0.36.1
  • php5-pear >= 5.2.14-0.36.1
  • php5-pgsql >= 5.2.14-0.36.1
  • php5-posix >= 5.2.14-0.36.1
  • php5-pspell >= 5.2.14-0.36.1
  • php5-shmop >= 5.2.14-0.36.1
  • php5-snmp >= 5.2.14-0.36.1
  • php5-soap >= 5.2.14-0.36.1
  • php5-sockets >= 5.2.14-0.36.1
  • php5-sqlite >= 5.2.14-0.36.1
  • php5-suhosin >= 5.2.14-0.36.1
  • php5-sysvmsg >= 5.2.14-0.36.1
  • php5-sysvsem >= 5.2.14-0.36.1
  • php5-sysvshm >= 5.2.14-0.36.1
  • php5-tokenizer >= 5.2.14-0.36.1
  • php5-wddx >= 5.2.14-0.36.1
  • php5-xmlreader >= 5.2.14-0.36.1
  • php5-xmlrpc >= 5.2.14-0.36.1
  • php5-xsl >= 5.2.14-0.36.1
  • php5-zlib >= 5.2.14-0.36.1
sle10-sp4-sdk.x86
sles10-sp4-debuginfo.x86
sles10-sp4.ia64
sles10-sp4.ppc
sles10-sp4-debuginfo.ppc
sle10-sp4-sdk.s390x
sle10-sp4-sdk.ppc
sles10-sp4.x86-64
sle10-sp4-sdk.ia64
sles10-sp4.x86
sles10-sp4.s390x
sles10-sp4-debuginfo.x86-64
sles10-sp4-debuginfo.s390x
sles10-sp4-debuginfo.ia64
sle10-sp4-sdk.x86-64
ZYPP Patch Nr: 8239
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • apache2-mod_php5 >= 5.2.14-0.7.30.42.1
  • php5 >= 5.2.14-0.7.30.42.1
  • php5-bcmath >= 5.2.14-0.7.30.42.1
  • php5-bz2 >= 5.2.14-0.7.30.42.1
  • php5-calendar >= 5.2.14-0.7.30.42.1
  • php5-ctype >= 5.2.14-0.7.30.42.1
  • php5-curl >= 5.2.14-0.7.30.42.1
  • php5-dba >= 5.2.14-0.7.30.42.1
  • php5-dbase >= 5.2.14-0.7.30.42.1
  • php5-devel >= 5.2.14-0.7.30.42.1
  • php5-dom >= 5.2.14-0.7.30.42.1
  • php5-exif >= 5.2.14-0.7.30.42.1
  • php5-fastcgi >= 5.2.14-0.7.30.42.1
  • php5-ftp >= 5.2.14-0.7.30.42.1
  • php5-gd >= 5.2.14-0.7.30.42.1
  • php5-gettext >= 5.2.14-0.7.30.42.1
  • php5-gmp >= 5.2.14-0.7.30.42.1
  • php5-hash >= 5.2.14-0.7.30.42.1
  • php5-iconv >= 5.2.14-0.7.30.42.1
  • php5-imap >= 5.2.14-0.7.30.42.1
  • php5-json >= 5.2.14-0.7.30.42.1
  • php5-ldap >= 5.2.14-0.7.30.42.1
  • php5-mbstring >= 5.2.14-0.7.30.42.1
  • php5-mcrypt >= 5.2.14-0.7.30.42.1
  • php5-mysql >= 5.2.14-0.7.30.42.1
  • php5-ncurses >= 5.2.14-0.7.30.42.1
  • php5-odbc >= 5.2.14-0.7.30.42.1
  • php5-openssl >= 5.2.14-0.7.30.42.1
  • php5-pcntl >= 5.2.14-0.7.30.42.1
  • php5-pdo >= 5.2.14-0.7.30.42.1
  • php5-pear >= 5.2.14-0.7.30.42.1
  • php5-pgsql >= 5.2.14-0.7.30.42.1
  • php5-posix >= 5.2.14-0.7.30.42.1
  • php5-pspell >= 5.2.14-0.7.30.42.1
  • php5-readline >= 5.2.14-0.7.30.42.1
  • php5-shmop >= 5.2.14-0.7.30.42.1
  • php5-snmp >= 5.2.14-0.7.30.42.1
  • php5-soap >= 5.2.14-0.7.30.42.1
  • php5-sockets >= 5.2.14-0.7.30.42.1
  • php5-sqlite >= 5.2.14-0.7.30.42.1
  • php5-suhosin >= 5.2.14-0.7.30.42.1
  • php5-sysvmsg >= 5.2.14-0.7.30.42.1
  • php5-sysvsem >= 5.2.14-0.7.30.42.1
  • php5-sysvshm >= 5.2.14-0.7.30.42.1
  • php5-tidy >= 5.2.14-0.7.30.42.1
  • php5-tokenizer >= 5.2.14-0.7.30.42.1
  • php5-wddx >= 5.2.14-0.7.30.42.1
  • php5-xmlreader >= 5.2.14-0.7.30.42.1
  • php5-xmlrpc >= 5.2.14-0.7.30.42.1
  • php5-xmlwriter >= 5.2.14-0.7.30.42.1
  • php5-xsl >= 5.2.14-0.7.30.42.1
  • php5-zip >= 5.2.14-0.7.30.42.1
  • php5-zlib >= 5.2.14-0.7.30.42.1
sle11-sp2-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sles11-sp2.ia64
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sle11-sp2-sdk.ia64
sle11-sp1-sdk.x86-64
sles11-sp1.s390x
sles11-sp2.x86
sles11-sp1.x86
sles11-sp2.ppc
sle11-sp2-sdk.ppc
sles11-sp1-vmware.x86
sles11-sp1.ppc
sle11-sp2-sdk.x86
sle11-sp1-sdk.ppc
sles11-sp2.s390x
sles11-sp1.ia64
sle11-sp2-sdk.s390x
SAT Patch Nr: 6627
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • php5-devel >= 5.2.14-0.7.30.42.1
  • php5-imap >= 5.2.14-0.7.30.42.1
  • php5-ncurses >= 5.2.14-0.7.30.42.1
  • php5-posix >= 5.2.14-0.7.30.42.1
  • php5-readline >= 5.2.14-0.7.30.42.1
  • php5-sockets >= 5.2.14-0.7.30.42.1
  • php5-sqlite >= 5.2.14-0.7.30.42.1
  • php5-tidy >= 5.2.14-0.7.30.42.1
sle11-sp2-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sles11-sp2.ia64
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sle11-sp2-sdk.ia64
sle11-sp1-sdk.x86-64
sles11-sp1.s390x
sles11-sp2.x86
sles11-sp1.x86
sles11-sp2.ppc
sle11-sp2-sdk.ppc
sles11-sp1-vmware.x86
sles11-sp1.ppc
sle11-sp2-sdk.x86
sle11-sp1-sdk.ppc
sles11-sp2.s390x
sles11-sp1.ia64
sle11-sp2-sdk.s390x
SAT Patch Nr: 6627
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • apache2-mod_php5 >= 5.2.14-0.7.30.42.1
  • php5 >= 5.2.14-0.7.30.42.1
  • php5-bcmath >= 5.2.14-0.7.30.42.1
  • php5-bz2 >= 5.2.14-0.7.30.42.1
  • php5-calendar >= 5.2.14-0.7.30.42.1
  • php5-ctype >= 5.2.14-0.7.30.42.1
  • php5-curl >= 5.2.14-0.7.30.42.1
  • php5-dba >= 5.2.14-0.7.30.42.1
  • php5-dbase >= 5.2.14-0.7.30.42.1
  • php5-dom >= 5.2.14-0.7.30.42.1
  • php5-exif >= 5.2.14-0.7.30.42.1
  • php5-fastcgi >= 5.2.14-0.7.30.42.1
  • php5-ftp >= 5.2.14-0.7.30.42.1
  • php5-gd >= 5.2.14-0.7.30.42.1
  • php5-gettext >= 5.2.14-0.7.30.42.1
  • php5-gmp >= 5.2.14-0.7.30.42.1
  • php5-hash >= 5.2.14-0.7.30.42.1
  • php5-iconv >= 5.2.14-0.7.30.42.1
  • php5-json >= 5.2.14-0.7.30.42.1
  • php5-ldap >= 5.2.14-0.7.30.42.1
  • php5-mbstring >= 5.2.14-0.7.30.42.1
  • php5-mcrypt >= 5.2.14-0.7.30.42.1
  • php5-mysql >= 5.2.14-0.7.30.42.1
  • php5-odbc >= 5.2.14-0.7.30.42.1
  • php5-openssl >= 5.2.14-0.7.30.42.1
  • php5-pcntl >= 5.2.14-0.7.30.42.1
  • php5-pdo >= 5.2.14-0.7.30.42.1
  • php5-pear >= 5.2.14-0.7.30.42.1
  • php5-pgsql >= 5.2.14-0.7.30.42.1
  • php5-pspell >= 5.2.14-0.7.30.42.1
  • php5-shmop >= 5.2.14-0.7.30.42.1
  • php5-snmp >= 5.2.14-0.7.30.42.1
  • php5-soap >= 5.2.14-0.7.30.42.1
  • php5-suhosin >= 5.2.14-0.7.30.42.1
  • php5-sysvmsg >= 5.2.14-0.7.30.42.1
  • php5-sysvsem >= 5.2.14-0.7.30.42.1
  • php5-sysvshm >= 5.2.14-0.7.30.42.1
  • php5-tokenizer >= 5.2.14-0.7.30.42.1
  • php5-wddx >= 5.2.14-0.7.30.42.1
  • php5-xmlreader >= 5.2.14-0.7.30.42.1
  • php5-xmlrpc >= 5.2.14-0.7.30.42.1
  • php5-xmlwriter >= 5.2.14-0.7.30.42.1
  • php5-xsl >= 5.2.14-0.7.30.42.1
  • php5-zip >= 5.2.14-0.7.30.42.1
  • php5-zlib >= 5.2.14-0.7.30.42.1
sle11-sp2-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sle11-sp1-sdk.ia64
sles11-sp2.ia64
sle11-sp1-sdk.x86
sles11-sp1-vmware.x86-64
sles11-sp2.x86-64
sle11-sp2-sdk.ia64
sle11-sp1-sdk.x86-64
sles11-sp1.s390x
sles11-sp2.x86
sles11-sp1.x86
sles11-sp2.ppc
sle11-sp2-sdk.ppc
sles11-sp1-vmware.x86
sles11-sp1.ppc
sle11-sp2-sdk.x86
sle11-sp1-sdk.ppc
sles11-sp2.s390x
sles11-sp1.ia64
sle11-sp2-sdk.s390x
SAT Patch Nr: 6627

© 2014 Novell