Novell Home

CVE-2012-2141

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2141 at MITRE

Description

Array index error in the handle_nsExtendOutput2Table function in agent/mibgroup/agent/extend.c in Net-SNMP 5.7.1 allows remote authenticated users to cause a denial of service (out-of-bounds read and snmpd crash) via an SNMP GET request for an entry not in the extension table.

NVD CVSS v2 Base Score: 3.5 (AV:N/AC:M/Au:S/C:N/I:N/A:P)

Novell/SUSE information

Novell Bugzilla entry: 759352, 826684

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • net-snmp >= 5.3.0.1-25.43.1
  • net-snmp-devel >= 5.3.0.1-25.43.1
  • perl-SNMP >= 5.3.0.1-25.43.1
Builds
ZYPP Patch Nr: 8153
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • net-snmp-devel >= 5.3.0.1-25.43.1
Builds
ZYPP Patch Nr: 8153
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
  • net-snmp-devel >= 5.3.0.1-25.43.1
  • net-snmp-devel-64bit >= 5.3.0.1-25.43.1
Builds
ZYPP Patch Nr: 8153
SUSE Linux Enterprise Server 10 SP4 for IPF
  • net-snmp >= 5.3.0.1-25.43.1
  • net-snmp-devel >= 5.3.0.1-25.43.1
  • net-snmp-x86 >= 5.3.0.1-25.43.1
  • perl-SNMP >= 5.3.0.1-25.43.1
Builds
ZYPP Patch Nr: 8153
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • net-snmp >= 5.3.0.1-25.43.1
  • net-snmp-64bit >= 5.3.0.1-25.43.1
  • net-snmp-devel >= 5.3.0.1-25.43.1
  • net-snmp-devel-64bit >= 5.3.0.1-25.43.1
  • perl-SNMP >= 5.3.0.1-25.43.1
Builds
ZYPP Patch Nr: 8153
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • net-snmp >= 5.3.0.1-25.43.1
  • net-snmp-32bit >= 5.3.0.1-25.43.1
  • net-snmp-devel >= 5.3.0.1-25.43.1
  • perl-SNMP >= 5.3.0.1-25.43.1
Builds
ZYPP Patch Nr: 8153
SLE 11 SP1 DEBUGINFO
  • net-snmp-debuginfo >= 5.4.2.1-8.12.10.1
  • net-snmp-debugsource >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • net-snmp-devel >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • net-snmp-devel >= 5.4.2.1-8.12.10.1
  • net-snmp-devel-32bit >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libsnmp15-32bit >= 5.4.2.1-8.12.10.1
  • net-snmp-devel >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libsnmp15 >= 5.4.2.1-8.12.10.1
  • net-snmp >= 5.4.2.1-8.12.10.1
  • perl-SNMP >= 5.4.2.1-8.12.10.1
  • snmp-mibs >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libsnmp15 >= 5.4.2.1-8.12.10.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.10.1
  • net-snmp >= 5.4.2.1-8.12.10.1
  • perl-SNMP >= 5.4.2.1-8.12.10.1
  • snmp-mibs >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libsnmp15 >= 5.4.2.1-8.12.10.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.10.1
  • net-snmp >= 5.4.2.1-8.12.10.1
  • perl-SNMP >= 5.4.2.1-8.12.10.1
  • snmp-mibs >= 5.4.2.1-8.12.10.1
Builds
SAT Patch Nr: 6517

© 2014 Novell