Novell Home

CVE-2012-2131

Common Vulnerabilities and Exposures

[Previous] [Index] [Next]

Upstream information

CVE-2012-2131 at MITRE

Description

Multiple integer signedness errors in crypto/buffer/buffer.c in OpenSSL 0.9.8v allow remote attackers to conduct buffer overflow attacks, and cause a denial of service (memory corruption) or possibly have unspecified other impact, via crafted DER data, as demonstrated by an X.509 certificate or an RSA public key. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-2110.

NVD CVSS v2 Base Score: 7.5 (AV:N/AC:L/Au:N/C:P/I:P/A:P)

Novell/SUSE information

Novell Bugzilla entry: 758060

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Software Development Kit 11 SP2
  • libopenssl-devel >= 0.9.8j-0.36.1
Builds
SAT Patch Nr: 6245
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.36.1
  • openssl >= 0.9.8j-0.36.1
Builds
SAT Patch Nr: 6245
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.36.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.36.1
  • openssl >= 0.9.8j-0.36.1
Builds
SAT Patch Nr: 6245
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.36.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.36.1
  • openssl >= 0.9.8j-0.36.1
  • openssl-doc >= 0.9.8j-0.36.1
Builds
SAT Patch Nr: 6245
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.36.1
  • openssl >= 0.9.8j-0.36.1
  • openssl-doc >= 0.9.8j-0.36.1
Builds
SAT Patch Nr: 6245
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.36.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.36.1
  • openssl >= 0.9.8j-0.36.1
  • openssl-doc >= 0.9.8j-0.36.1
Builds
SAT Patch Nr: 6245
SUSE Linux Enterprise Server 10 SP3 LTSS for x86
  • openssl >= 0.9.8a-18.45.63.1
  • openssl-devel >= 0.9.8a-18.45.63.1
  • openssl-doc >= 0.9.8a-18.45.63.1
Builds
ZYPP Patch Nr: 8142
SUSE Linux Enterprise Server 10 SP3 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP3 LTSS for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.45.63.1
  • openssl-32bit >= 0.9.8a-18.45.63.1
  • openssl-devel >= 0.9.8a-18.45.63.1
  • openssl-devel-32bit >= 0.9.8a-18.45.63.1
  • openssl-doc >= 0.9.8a-18.45.63.1
Builds
ZYPP Patch Nr: 8142
SUSE Linux Enterprise for SAP Applications 11 SP1
  • compat-openssl097g >= 0.9.7g-146.22.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.1
sle11-sap-sp1.x86-64
SAT Patch Nr: 6759
SUSE Linux Enterprise Desktop 10 SP4 for x86
SUSE Linux Enterprise Server 10 SP4 for x86
  • compat-openssl097g >= 0.9.7g-13.23.1
sles10-sp4.ia64
sled10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
sles10-sp4.x86-64
sles10-sp4.x86
sled10-sp4.x86-64
ZYPP Patch Nr: 8262
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • compat-openssl097g >= 0.9.7g-13.23.1
  • compat-openssl097g-32bit >= 0.9.7g-13.23.1
sles10-sp4.ia64
sled10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
sles10-sp4.x86-64
sles10-sp4.x86
sled10-sp4.x86-64
ZYPP Patch Nr: 8262
SUSE Linux Enterprise Server 10 SP4 for IPF
  • compat-openssl097g >= 0.9.7g-13.23.1
  • compat-openssl097g-x86 >= 0.9.7g-13.23.1
sles10-sp4.ia64
sled10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
sles10-sp4.x86-64
sles10-sp4.x86
sled10-sp4.x86-64
ZYPP Patch Nr: 8262
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • compat-openssl097g >= 0.9.7g-13.23.1
  • compat-openssl097g-64bit >= 0.9.7g-13.23.1
sles10-sp4.ia64
sled10-sp4.x86
sles10-sp4.s390x
sles10-sp4.ppc
sles10-sp4.x86-64
sles10-sp4.x86
sled10-sp4.x86-64
ZYPP Patch Nr: 8262
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise for SAP Applications 11 SP2
  • compat-openssl097g >= 0.9.7g-146.22.1
  • compat-openssl097g-32bit >= 0.9.7g-146.22.1
sle11-sap-sp2.x86-64
sled11-sp2.x86-64
SAT Patch Nr: 6749
SUSE CORE 9 for AMD64 and Intel EM64T
  • openssl >= 0.9.7d-15.54
  • openssl-32bit >= 9-201205031628
  • openssl-devel >= 0.9.7d-15.54
  • openssl-devel-32bit >= 9-201205031628
  • openssl-doc >= 0.9.7d-15.54
Builds
YOU Patch Nr: 12883
SUSE CORE 9 for IBM S/390 31bit
SUSE CORE 9 for x86
  • openssl >= 0.9.7d-15.48
  • openssl-devel >= 0.9.7d-15.48
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12972
SUSE CORE 9 for IBM zSeries 64bit
  • openssl >= 0.9.7d-15.48
  • openssl-32bit >= 9-201308121642
  • openssl-devel >= 0.9.7d-15.48
  • openssl-devel-32bit >= 9-201308121642
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12972
SUSE CORE 9 for AMD64 and Intel EM64T
  • openssl >= 0.9.7d-15.48
  • openssl-32bit >= 9-201308121627
  • openssl-devel >= 0.9.7d-15.48
  • openssl-devel-32bit >= 9-201308121627
  • openssl-doc >= 0.9.7d-15.48
Builds
YOU Patch Nr: 12972
SUSE Linux Enterprise Desktop 10 SP4 for x86
  • openssl >= 0.9.8a-18.68.1
  • openssl-devel >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112
SUSE Linux Enterprise Desktop 10 SP4 for AMD64 and Intel EM64T
  • openssl >= 0.9.8a-18.68.1
  • openssl-32bit >= 0.9.8a-18.68.1
  • openssl-devel >= 0.9.8a-18.68.1
  • openssl-devel-32bit >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112
SLE SDK 10 SP4 for IBM iSeries and IBM pSeries
SLE SDK 10 SP4 for IBM zSeries
SLE SDK 10 SP4 for IPF
SLE SDK 10 SP4 for X86-64
SLE SDK 10 SP4 for x86
  • openssl-doc >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112
SUSE Linux Enterprise Server 10 SP4 for x86
  • openssl >= 0.9.8a-18.68.1
  • openssl-devel >= 0.9.8a-18.68.1
  • openssl-doc >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112
SUSE Linux Enterprise Server 10 SP4 for IPF
  • openssl >= 0.9.8a-18.68.1
  • openssl-devel >= 0.9.8a-18.68.1
  • openssl-doc >= 0.9.8a-18.68.1
  • openssl-x86 >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112
SUSE Linux Enterprise Server 10 SP4 for IBM POWER
  • openssl >= 0.9.8a-18.68.1
  • openssl-64bit >= 0.9.8a-18.68.1
  • openssl-devel >= 0.9.8a-18.68.1
  • openssl-devel-64bit >= 0.9.8a-18.68.1
  • openssl-doc >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112
SUSE Linux Enterprise Server 10 SP4 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 for IBM zSeries 64bit
  • openssl >= 0.9.8a-18.68.1
  • openssl-32bit >= 0.9.8a-18.68.1
  • openssl-devel >= 0.9.8a-18.68.1
  • openssl-devel-32bit >= 0.9.8a-18.68.1
  • openssl-doc >= 0.9.8a-18.68.1
Builds
ZYPP Patch Nr: 8112

© 2014 Novell